How to Use USRP in LabVIEW and LabVIEW Communications Design Suite?

Updated Apr 8, 2019

Reported In

Hardware

  • USRP Software Defined Radio Device
  • USRP-2900
  • USRP-2920
  • USRP-2932
  • USRP-2943
  • USRP-2953

Software

  • LabVIEW NXG
  • LabVIEW
  • LabVIEW Communications System Design Suite
  • LabVIEW Communications System Design Software

Issue Details

I did a system format and reinstalled LabVIEW 2018, LabVIEW Communications Design Suite 3.0, and NI-USRP 18.5. In LabVIEW Communications Design Suite 3.0, my USRP device can be recognized but not in LabVIEW 2018.
Why does this happen?

Solution

The latest USRP device driver to support LabVIEW 2018 is the NI-USRP 18.1. NI-USRP 18.3 and NI-USRP 18.5 only support LabVIEW NXG 2.1/LabVIEW Communications Design Suite 2.1 and LabVIEW NXG 3.0/LabVIEW Communications Design Suite 3.0, respectively.
To use NI-USRP devices in both LabVIEW 2018 and LabVIEW Communications Design Suite 3.0, you should install both NI-USRP 18.1 and NI-USRP 18.5 for LabVIEW 2018 and LabVIEW Communications Design Suite 3.0, respectively.

If your USRP device is not still recognized in LabVIEW after installing the proper driver, please check your connection between the USRP device and the host system.

WAS THIS ARTICLE HELPFUL?

Not Helpful