LabVIEW FPGA中未安装软件支持

更新 May 27, 2019

问题详述

当我打开一个使用了FPGA终端(FPGA Target)的LabVIEW项目时,我的FPGA终端被替换为黄色感叹号:

当我单击解释警告(Explan Warning)时,我收到以下两个错误之一:
  • 计算机上未安装此FPGA终端的软件支持。您可以查看和复制项目中的某些项,但在安装终端支持之前,您无法在此FPGA终端下编译任何VI。有关相应驱动程序以及安装和配置FPGA终端的信息,请参阅指定的硬件文档。
  • 您的系统上未安装所选项的插件,或者插件的许可证已过期。请联系National Instruments。

我该如何解决这个问题?

解决方案

此错误消息表示LabVIEW开发环境与LabVIEW FPGA模块之间未连接。请按照以下步骤解决此问题:
  1. 在NI Measurement and Automation Explorer(MAX)中,确认您已安装FPGA模块。查看我的系统(My System)>>软件(Software)>> LabVIEW(版本),并验证FPGA是否在您的LabVIEW版本的下拉菜单中。 注意: LabVIEW FPGA模块仅与LabVIEW完整版和LabVIEW专业版兼容。 LabVIEW FPGA模块也只与相同版本的LabVIEW兼容。

  1. 检查NI许可证管理器以确保FPGA模块具有有效许可证。有关确认许可证状态的更多信息,请参阅“NI许可证管理器中的颜色标志含义 ”。
  2. 检查NI MAX以确保您安装了与LabVIEW版本和硬件兼容的NI-RIO驱动程序版本。
    1. NI-RIO和LabVIEW版本兼容性
    2. CompactRIO,CompactDAQ,单板RIO,R系列和EtherCAT的软件支持
  3. 确保按照正确的软件安装顺序进行操作,如“安装多个NI产品时的安装顺序”所述。
  4. 如果您的FPGA模块已获得许可且出现在NI MAX中,但您仍然看到此错误,则可能是您的FPGA模块安装已损坏。
    1. 按照“ 强制重新安装不工作或损坏的NI软件”中列出的故障排除步骤强制重新安装FPGA模块。
    2. 按照“在Windows中卸载或修复NI软件或驱动程序”的步骤修复CompactRIO驱动程序(按照正确的软件安装顺序)。

相关信息

注意:从LabVIEW 2015开始,NI-RIO分为三个独立的安装程序。
  • CompactRIO设备驱动程序(支持CompactRIO和单板RIO)。
  • R系列多功能(支持R系列卡)。
  • FlexRIO(支持FlexRIO板卡)。
NI-RIO和LabVIEW兼容性表适用于所有单独的安装程序。

本文是否有帮助?

无帮助