Remote Front Panels,NI Network Browser或WIF在瀏覽器中不起作用

更新 May 17, 2021

產品資訊

硬件

  • CompactRIO Controller

軟體

  • LabVIEW

其他

  • Google Chrome
  • Mozilla Firefox
  • Safari macOS Mojave

問題敘述

使用谷歌瀏覽器,Mozilla Firefox或Safari時,無法存取 Remote Front Panels, NI Network Browser或Web界面(WIF)。我收到類似於以下內容的錯誤訊息:
  • This plugin is not supported.
  • NI has detected that your browser might be blocking a plug-in. Visit ni.com/info and enter the following Info Code for more information: BlockedPlugin

在Web瀏覽器中,我看到類似於以下內容的錯誤訊息:

在Chrome中看到的錯誤
 

firefox error

在Firefox中看到的錯誤

 

在Safari中看到的錯誤
 

解決方案

NI強烈建議客戶使用支援的瀏覽器(Internet Explorer)。

在以往,其他瀏覽器能夠通過利用稱為Netscape Plugin Application Programming Interface (NPAPI)的瀏覽器插件機制來顯示“Remote Front Panels”。從42版開始的Google Chrome瀏覽器,從52版開始的Mozilla Firefox和macOS Mojave 10.14版的Safari 12.1 已棄用此插件機制。

因此,這些較舊的NI網絡技術不支援 Google Chrome瀏覽器42版及更高版本,Mozilla Firefox 52及更高版本,macOS Mojave 10.14中的Safari 12.1和Microsoft Edge瀏覽器。

相關資訊

要確定問題的根源是基於不建議使用的插件機制,請檢查您使用的瀏覽器版本。
  • 谷歌瀏覽器:單擊“自定義和控制谷歌瀏覽器”菜單(右上角的三個點菜單)>>説明>>關於Google Chrome檢查您的版本。
  • Firefox :您可以通過單擊Open menu  >> Open Help Menu >> About Firefox菜單項來檢查Mozilla Firefox的版本。
  • Safari :您可以檢查擁有的macOS版本,也可以通過單擊菜單欄中的Safari > About Safari檢查Safari版本。

在Mozilla Firefox 52版發佈之後,NPAPI插件可能會在Mozilla Firefox擴展支援版本中繼續工作一段時間。如果您遇到舊版Firefox缺少插件的問題,則可以還原這些插件

LabVIEW NXG Web模組SystemLink等較新的Web技術支援最新版本的Chrome,Firefox,Safari和Edge。有關更多詳細訊息,請參閲這些產品的自述文件(Readme)。