LabVIEW与实时模块和LabVIEW FPGA模块的兼容性

更新 Oct 28, 2020

适用于

软件

  • LabVIEW
  • LabVIEW Real-Time Module
  • LabVIEW FPGA Module

问题详述

我需要使用哪个版本的LabVIEW Real-Time和LabVIEW FPGA模块才能使用当前版本的LabVIEW?

解决方案

要将当前版本的LabVIEW与LabVIEW Real-Time和LabVIEW FPGA模块一起使用,您需要安装与您使用的年份相对应的模块。如果要升级到某个软件的较新版本,则还必须升级到其他软件的相应版本。

例如:对于LabVIEW 2018,您需要LabVIEW Real-Time 2018和LabVIEW FPGA 2018。

相关信息

LabVIEW模块仅与其所构建的版本兼容。有关兼容性的更多信息,请查看每个模块的自述文件。仅当存在LabVIEW Module的SP1版本时,SP1版本也是如此。
您可以查看LabVIEW FPGA模块LabVIEW Real-Time模块的下载页面,以查看该年是否发布了SP1版本。

例如

  • LabVIEW 2017 SP1的兼容版本如下:
    • LabVIEW Real-Time模块2017
    • LabVIEW FPGA模块2017 SP1
  • LabVIEW 2018 SP1的兼容模块如下:
    • LabVIEW Real-Time模块2018 SP1
    • LabVIEW FPGA模块2018


在开发计算机上安装LabVIEW,LabVIEW模块和NI驱动程序时,安装软件的顺序很重要。请按照本指南安装软件产品:安装LabVIEW,LabVIEW Real-Time和FPGA模块以及NI-RIO