Error -250891 or -250890 The SLSC Chassis Firmware Is Older/Newer Than the NI-SLSC Driver

Updated Dec 10, 2021

Reported In

Hardware

  • SLSC-12001

Driver

  • NI-SLSC

Issue Details

  • I get one of the following error when deploying my VeriStand project.
Error -250891 occurred at Project Window.lvlib:Project Window.vi >> Project Window.lvlib:Command Loop.vi >> Project Window.lvlib:Connect to System.vi 

Possible reason(s): 
The SLSC chassis firmware is older than the NI-SLSC driver. Upgrade the firmware or downgrade the driver to use the chassis.

Error -250891 - SLSC Firmware mismatch
 

Error -250890 occurred at Project Window.lvlib:Project Window.vi >> Project Window.lvlib:Command Loop.vi >> Project Window.lvlib:Connect to System.vi

Possible reason(s):
The SLSC chassis firmware is newer than the NI-SLSC driver. Upgrade the driver or downgrade the firmware to use the chassis.
  • ​​​​​I get one of the above errors when running my LabVIEW VI.

Solution

The firmware version on the target SLSC chassis does not match that of the NI-SLSC driver installed on the host device and, if using VeriStand, the target being deployed to.

To resolve this: 
  1. Update the firmware of the target SLSC chassis to the matching version.
  2. Retry the deployment or run the application again.

Alternatively:
  1. Uninstall the NI-SLSC driver from the host & target.
  2. Install the version that matches the firmware on the SLSC chassis.