Firmware Not in Sync With Software Error With NI-XNET

Updated Mar 2, 2020

Reported In

Hardware

  • PXIe-8510

Driver

  • NI-XNET

Issue Details

In NI-MAX, my PXIe-8510 is not recognized and displays with the following error message "The Firmware version of your NI-XNET hardware is not in sync with your software. Use the 'Use the Update Firmware' button to resolve this issue". However, when I try to update the firmware, another error message states "There was a problem updating the firmware for this device".

What can I do to resolve this issue?

Solution

Make sure you are using the most updated version of the NI-XNET driver that is compatible with your other software. If the system was already updated to the most recent driver, try to uninstall/reinstall your NI-XNET driver as this issue is likely related to the driver installation.