Error When Deploying SoftMotion Modules

Updated Mar 31, 2020

Reported In

Hardware

  • Motion Controller Device

Software

  • LabVIEW
  • LabVIEW Real-Time Module
  • LabVIEW SoftMotion Module

Driver

  • NI CompactRIO

Issue Details

I'm seeing an error when trying to open the soft panels in SoftMotion saying: 

Some of the NI SoftMotion Module components are missing, incompatible, or not properly started

How can I fix this? 
 

Solution

This error is generated by your development environment when it's unable to contact the SoftMotion software on the target you're trying to deploy to.  
 

First, confirm that SoftMotion is installed on your Real-Time target. To check this, go into Measurement and Automation Explorer (MAX) and click Remote Systems >> [Your Target] >> Software. If SoftMotion is not installed, follow the steps to install Software on your Target. If SoftMotion is installed, the following could be solutions/reasons for receiving this error: 

  1. Make sure all installed packages are compatible: As the last version of SoftMotion to be released is 2018, Make sure LabVIEW, LabVIEW Real-Time, LabVIEW FPGA and NI Compact RIO are all version 2018 or older depending on your version of SoftMotion. 
  2. Make sure all packages on the target are compatible with the ones on the development system: Go into Measurement and Automation Explorer (MAX) and click Remote Systems >> [Your Target] >> Software, here you can check that all major packages (LabVIEW Real-Time, NI RIO, NI SoftMotion) are compatible. 

If you're still experiencing issues after this, contact NI Support

Additional Information

To to check SoftMotion compatibility for your version refer to the ReadMe page for the product. Usually you need the same version number, E.g. LabVIEW 2018 along with SoftMotion 18 as you can see in the SoftMotion ReadMe.