Merging two VeriStand Systems

Updated Feb 14, 2020

Issue Details

I have two or more system definition files in VeriStand that I built for independent debugging or other reason. These have configured devices, aliases, procedures and screens. I now wish to merge these VeriStand projects into one system definition file. How do I do this?

Solution

VeriStand does not natively have a full merge function built into it. However, the projects can be merged in steps. 
  1. Targets: In the VeriStand System Explorer, it is possible to select a target, go to Edit->Copy, open another System Definition file and Edit->Paste to insert the Target into the new system definition file.
  2. Aliases:  Aliases can be exported via right-clicking Aliases -> Export Aliases, saving as an ASCII file and then imported via right-clicking Aliases -> Import Aliases in the new System Definition file. 
  3. Scales: Scales can be imported via right-clicking Scales -> Import Scales in the new System Definition file and pointing to the correct file
  4. System Mappings: System Mappings can be exported and imported using System Configuration Mappings Explorer.
  5. Screens: To merge screens, go to File->Add File -> navigate to the screen and add this to the project. Ensure that the mappings are correct.

Additional Information

It is also possible to merge systems by editing the .sysdef XML description and merging the files together. However, this is recommended for advanced users only.