DAQmx Gives Dependency Errors When Installing on cRIO

Updated Dec 5, 2019

Reported In

Hardware

  • cRIO-9040

Issue Details

I am trying to install NI-DAQmx onto my CompactRIO-904x or 905x series. However, when trying to do so, I receive the following message:
Cannot continue because of the following unresolved dependencies:

NI-DAQmx OPC Server Software (hidden) 19.5.0 requires Network Variable Engine 1.0.0
NI-DAQmx OPC Server Software (hidden) 19.5.0 requires Variable Client Support 1.4.0

Possible reason: The feature's Real-Time support for this target type may not be installed.


How do I fix this?

 

Solution

This message will appear if you do not have the LabVIEW Real-Time Module installed. To fix this, install the relevant LabVIEW Real-Time Module on your host PC and then install NI-DAQmx on the CompactRIO.
The Real-Time Module can be downloaded here .