Unable to Upgrade to LabVIEW 2017 SP1 or LabVIEW 2018 SP1

Updated Nov 27, 2019

Reported In

Software

  • LabVIEW 2017
  • LabVIEW 2018
  • LabVIEW 2017 SP1
  • LabVIEW 2018 SP1
  • System Configuration

Issue Details

  • When trying to upgrade LabVIEW 2017 or 2018 to LabVIEW 2017 or 2018 SP1, it will not be possible to install LabVIEW 2017 or 2018 SP1. Instead, the option to install LabVIEW 2017 or 2018 SP1 will not be selectable. 

Solution

To resolve this problem:
  1. Completely uninstall LabVIEW 2017 or 2018 LabVIEW and anything that depends on it.
  2. Install the corresponding SP1 version of LabVIEW.
  3. Reinstall any Toolkits, Modules, or Driver API Support required for LabVIEW 2017 or 2018 SP1.

Additional Information

This problem is a result of installer logic changes during the migration of installers to the NI Package Manager format.