Can I Use LabVIEW WSN Products in Versions Later than LabVIEW 2015?

Updated Jan 5, 2021

Reported In

Software

  • LabVIEW Wireless Sensor Network Module

Driver

  • NI-WSN

Issue Details

  • I'm looking to create an NI Wireless Sensor Network application, but would like to use LabVIEW 2016 or newer. Is there a compatible version of the NI-WSN software that I should use?
  • I'm looking to upgrade an existing NI Wireless Sensor Network application. What is the newest version of LabVIEW that I'll be able to upgrade to?

Solution

NI Wireless Sensor Network hardware and software, like NI-WSN, the LabVIEW WSN Module Pioneer, and any NI-WSN modules are not compatible with LabVIEW versions following LabVIEW 2015 SP1. NI advises against creating any new applications with WSN devices, and any existing applications will only be able to be upgraded to LabVIEW 2015 SP1.