CmtNA LabVIEW Example Had Some Issue When Measuring

Updated Nov 10, 2020

Reported In

Hardware

  • CMT PXIe-S5090

Software

  • LabVIEW

Driver

  • FlexRIO

Issue Details

We could find two exmple VI for S5090 after installed the software drivers. When i try to run the example VI , we will find some issue .

1.  Example VIs set the simulate mode as the default value "simulate=true"

Example 1:

Example 2:

 

2. When i run the example VI , it will show below error information

 

Solution

1. Because the S2VNA software is non-simulate status now , it is different from the LV example setting.
If you want to avoid  the error when running the example with simulate mode , you should set the S2VNA as simulate mode first . 

When open the S2VNA sub-window , you should select the simulate mode and then click the "Run" button;

 

Below is the S11 Log Mag measurement result with simulate mode . (Port1 is open status)


 

In simulate mode , the above result still was not any change when connect some other component or  open status . 

2. Because the simulate mode is not real measuring mode , it is just simulated some data for POC or Demo to introduce the basic functions of VNA. When you measure the real parameters for DUT , you should used the non-simulate mode. 

Below is the S11 Log Mag measurement result with non-simulate mode . (Port1 is open status)

Conclusion: The non-simulate mode is user's need testing mode . So you could modify the example as "simulate=false" first when measuring some parameters for DUT ;