Archived:NI-FieldPoint FP-160x Doesn't Work With LabVIEW 2012 or Newer

Updated Sep 3, 2020

National Instruments does not actively maintain this document.

This content provides support for older products and technology, so you may notice outdated links or obsolete information about operating systems or other relevant products.

Reported In

Hardware

  • FP-1601
  • FP-1600

Software

  • LabVIEW

Driver

  • NI-FieldPoint 6.0.10

Issue Details

I am in the process of updating an old LabVIEW-based system and my FP-160x hardware does not appear to work with LabVIEW 2012 or later and cannot be detected in NI MAX. What is keeping my hardware from communicating with my software?

Solution

With the release of the NI-FieldPoint 6.0.11 driver, support for FP-160x devices was removed. As NI-FieldPoint 6.0.11 was the first FieldPoint driver to support LabVIEW 2012, both the FP-1600 and the FP-1601 do not work with LabVIEW 2012. Further details can be found in the driver's Readme.

Support for FP-160x devices has not been added back into more recent NI-FieldPoint drivers. Consequently, LabVIEW 2011 with NI-FieldPoint 6.0.10 or 6.0.9 remains the most recent software package that works with the FP-160x device family. NI-FieldPoint 6.0.10 can be acquired from its download page.