USB機器との通信を設定する

更新しました Apr 24, 2021

環境

ソフトウェア

  • LabVIEW
  • Measurement & Automation Explorer (MAX)

ドライバ

  • NI-VISA

オペレーティング・システム

  • Windows

このチュートリアルでは、LabVIEWでUSB計測器と通信するようにNIソフトウェアを設定する方法を示します。

NI-VISAドライバは、USBテストおよび測定クラス(USBTMC)とUSB RAW機器の2つのクラスのUSB機器をサポートします。 USBTMC機器はUSBTMCプロトコルに準拠していますが、USBRAW機器は独自の通信プロトコルを使用しています。このチュートリアルでは、両方のタイプの計測器について説明します。

前提条件

機器をコンピュータに接続するためのUSBA-USBBケーブル があることを確認してください。


このチュートリアルは、機器の通信プロトコルに精通していることを前提としており、NIソフトウェアのセットアップの手順に焦点を当てています。セットアップ手順は、使用するプロトコルによって異なります。この情報については、USB機器のドキュメントを参照するか、機器の製造元にお問い合わせください。

 

NIソフトウェアとドライバをインストールする

LabVIEW と互換性のある最新のバージョンのNI-VISA ドライバをインストールします。互換性については、以下を参照してください。

 

ハードウェアのセットアップと構成

NIソフトウェアをインストールした後、USB機器を接続して構成します。


USBTMC機器

NI-VISAはUSBTMC機器を自動的に検出するため、NI-VISAドライバのインストール後に追加の設定は必要ありません。機器は、USBテストおよび測定クラス(USB Test & Measurement Class)のデバイスとしてインストールされます。

  1. USBケーブルを介してUSB機器をコンピュータにしっかりと接続します。
  2. スタートメニューからMeasurement and Automation Explorer(MAX)を開きます。
  3. デバイスとインターフェイス >> USBデバイスを展開します。 USBTMC機器のVISAリソース名がUSB [ボード] ::メーカーID ::モデルコード::シリアル番号:: [USBインターフェース番号] :: INSTRとしてリストされていることを確認します
  4. 通信テストセクションに進みます。

USBRAW機器

NI-VISAがUSBRAW機器を認識するためには、NI-VISAドライバーウィザードを使用してセットアップ情報ファイル(INFファイル)を作成し、コンピューターにインストールする必要があります。

INFファイルの作成(USBドライバー)

  1. スタートメニューからNI-VISAドライバウィザードを起動します。
  2. ハードウェアバスの選択ページで、USBを選択します。 次へをクリックします。

  1. デバイスの選択ページで、次のいずれかを実行します。
    • デバイスがすでにコンピューターに接続されている場合は、デバイスリストからデバイスを選択し、Nextをクリックします。リストにデバイスが表示されない場合は、デバイスがしっかりと接続されていることを確認し、Refreshを選択します。手順5に進みます。
    • デバイスが接続されていない/使用できない場合は、リストの下部にあるOther...を選択します。 Nextをクリックします。

  1. Other...を選択した場合は、USB –デバイス情報のページでデバイスに関する情報を手動で入力します。


ウィンドウの右上にあるクエスチョンマークをクリックします。これにより、コンテキストヘルプが有効になり、各入力項目の説明が表示されます。


USB Manufacture ID(Vender ID)USB Model Code(Product ID)を取得するには、USBデバイスのベンダIDと製品IDを調べるには? を参照してください。


フィールドに入力したら、Next をクリックします。以下の画像は、National InstrumentsのGPIB-USB-HSデバイスの例を示しています。

  1. 出力ファイルの生成ページで、Instrument Prefixの欄にINFファイルの名前を付け、保存する場所を指定します。 Nextをクリックします。
  2. インストールオプションページで、インストールオプションを指定します。
    • NI-VISAドライバーウィザードでINFファイルを自動的にインストールする場合は、Install the generated files on this computerを選択し、Finishをクリックします。これはデフォルトであり推奨のオプションです。 USB機器インストールセクションに進みます

:Install the generated files on this computerオプションを選択するには、管理者権限あるいは root権限が必要です。

  • INFファイルを自分でインストールする場合は、Do nothing and exit the wizardを選択して、Finishをクリックします。以下のセクションに進んでください。

INFファイルをインストールする

INFファイルを手動でインストールする場合は、INFファイルが作成された場所に移動し、任意のテキストエディター(メモ帳など)でINFファイルを開きます。インストール手順は、INFファイルの上部にあるヘッダーに含まれています。


詳細な手順については、以下の手順に従ってください。

  1. Windows 8以降のマシンを使用している場合は、最初にINFファイルに署名 して、コンピューターにインストールする必要があります。 Windows 7以前のマシンは、これを飛ばして次のステップにいけます。
  2. 管理者ユーザーアカウントでログインしていることを確認してください。
  3. この時点でUSB機器を取り外して、再インストール時にドライバーがデバイスに正しく関連付けられるようにします。
  4. INFファイルをC:\\Windows\INFにコピーします。 INFフォルダが表示されていない場合、表示させるためにツール>>フォルダオプション>>一覧>>詳細設定>>隠されたファイル、フォルダ、およびドライブで設定します。
  5. INFファイルを右クリックし、インストールをクリックします。これにより、デバイスのPNFファイルが作成されます。これで、USB機器をインストールする準備が整いました。

USB機器をインストールする

  1. USBケーブルを介してUSB機器をコンピュータにしっかりと接続します。
  2. デバイスを接続すると、新しいハードウェアの追加ウィザードが自動的に開きます。 Nextを選択します。 ハードウェアの追加ページで、Search for and install the hardware automatically (Recommended)を選択します。

  1. インストールの後、Windowsはデバイスが正常にインストールされたことを示します。
  2. スタートメニューからMeasurement and Automation Explorer (MAX)を開き、デバイスとインターフェイスを展開します。機器のVISAリソース名がUSB [ボード] ::メーカーID ::モデルコード::シリアル番号:: [USBインターフェース番号] :: RAWの形式で表示されます


一部のUSBRAW機器には、シリアル番号がない場合があります。この場合、NI-VISAは自動的にVISA固有のシリアル番号をNI-VISA-[number]の形式で割り当てます。


計測器が1つのインターフェースしかサポートしていない場合、VISAリソース名には表示されません。


場合によっては、WindowsにすでにUSB機器に関連付けられたデフォルトのドライバーがあり、そのドライバーを最初にインストールします。ドライバーをINFファイルに再度関連付けるには、以下の手順に従います。

  1. デバイスマネージャを開きます。
  2. リストから機器を見つけ、そのベンダーID(VID)と製品ID(PID)がINFファイルの作成に使用されたものと一致することを確認します。
  3. 機器を右クリックして、ドライバソフトウェアの更新を選択します。
  4. コンピューターを参照してドライバーソフトウェアを検索を選択します。
  5. コンピューター上の利用可能なドライバの一覧から選択しますを選択します。
  6. ディスク使用を選択します。
  7. C:\\Windows\INFに移動し、INFファイルを選択します。
  8. 次へをクリックします。
  9. 完了をクリックします。


テストコミュニケーション

セットアップと構成が完了したら、VISAテストパネルを使用して機器との通信を確認し、さまざまな機器コマンドをテストします。

  1. MAXで、ツールタブ>> NI-VISA >> VISAインタラクティブコントロールを選択します。
  2. USB機器のVISAリソース名を選択します。
  3. テストパネルウィンドウで、Input/Outputタブを選択します。
  4. Basic I / Oタブで、サポートされているコマンドを入力し、Queryを選択します。機器で使用するコマンドの有効なリストについては、製造元のドキュメントを参照してください。
  5. 表示ウィンドウには、書き込み操作と読み取り操作の結果が表示されます。
 

計測器ドライバをインストールする

設定を完了し、機器との通信を確認したら、インタラクティブモードからプログラミングモードに簡単に移行する必要があります。これを実現する最良の方法は、計測器ドライバを使用することです。

アプリケーションに最適な計測器ドライバのタイプを決定するには、この資料 を参照してください。ドキュメント内のリンクをたどって、計測器ドライバをインストールして使用します。

サンプルを実行する

計測器ドライバとNI-VISAドライバは、計測器との通信に必要なサンプルとAPIをインストールします。これらの例をプログラミングのリファレンスとして使用し、機器の使用を開始する簡単な方法として使用してください。


:LabVIEWサンプルの実行を開始する前にMAXを閉じてください。 MAXテストパネルを開いてLabVIEWサンプルを同時に実行すると、リソースへのアクセスエラーが発生します。


計測器ドライバのサンプル

計測器ドライバをインストールした場合は、次の例を参照してください。

  1. プラグアンドプレイ計測器ドライバの例
  2. IVI計測器ドライバの例


NI-VISAドライバーのサンプル

NI-VISAを使用している場合は、USB機器の種類に基づいて次の例を参照してください。

 

USBTMC機器

USBTMC機器の場合、NI-VISAAPIを使用して機器と通信できます。スニペットの例を以下に示します。この例では、USB計測器へのセッションを開き、* IDN?\ nの書き込みを実行し、計測器から返ってきた指定のバイト数を読み取り、セッションを閉じて、エラーを処理します。

  1. スニペットを右クリックして、画像として保存します。
  2. 画像を空のLabVIEWブロックダイアグラムに直接ドラッグします。
  3. フロントパネルで、VISAリソース名を、このチュートリアルで以前に構成した機器のVISAリソースになるように構成します。
  4. VIを実行します。

VISA関数の詳細については、 LabVIEWヘルプ:VISAVIおよび関数 を参照してください。


visa_usb_snippet.png

 

USBRAW機器

NI-VISA USB RAWモードは、割り込み、バルク、および制御データ転送をサポートします。アイソクロナス転送はサポートされていません。これらの通信タイプの詳細については、ヘルプ を参照してください。


USB RAWについて付属サンプルを確認するにはヘルプメニューからサンプルを検索… >>ハードウェア入力出力>> VISAに移動します。バルク、制御、および割り込み通信の例があります。


:NI-VISA USB RAWのサポートはデバイス固有であるため、デバイスの動作に関する詳細な知識が必要です。 USB RAW機器の通信プロトコルの詳細については、製造元のドキュメントを参照してください。