OPC를 사용하여 LabVIEW를 모든 PLC에 연결

업데이트 됨 Aug 17, 2021

환경

소프트웨어

  • LabVIEW
  • LabVIEW Datalogging and Supervisory Control Module
  • OPC Servers

운영 체제

  • Windows

NI LabVIEW 소프트웨어는 다양한 방식으로 프로그램 가능한 로직 컨트롤러 (PLC)와 통신할 수 있습니다. OLE for Process Control (OPC)은 제어 장치와 HMI (Human Machine Interface)간에 실시간 플랜트 데이터를 통신하기위한 표준을 정의합니다. OPC 서버는 거의 모든 PLC 및 프로그래밍 가능한 자동화 컨트롤러 (PAC)에서 사용할 수 있습니다. 이 튜토리얼에서는 LabVIEW를 사용하여 OPC를 사용하여 네트워크로 연결된 PLC와 통신하는 방법을 알아봅니다.

이 튜토리얼에서는 LabVIEW 데이터 로깅 및 감독 제어 (DSC) 모듈이 사용됩니다. 이 모듈에는 네트워크로 연결된 히스토리 데이터베이스에 데이터 로깅, 실시간 및 히스토리 트렌드, 알람 및 이벤트 관리, LabVIEW Real-Time 타겟 및 OPC 디바이스를 하나의 완전한 시스템으로 네트워킹하고 사용자 인터페이스에 보안을 추가하는 도구가 포함되어 있습니다. 이러한 기능을 통해 LabVIEW는 산업용 제어 어플리케이션을 위한 강력한 HMI/SCADA 패키지가 됩니다.

NI OPC Servers 2012로 기존 PLC 태그보기

이 섹션의 단계는 NI OPC 서버 2012용으로 작성되었지만 이전 버전의 NI OPC 서버에서도 유사한 단계를 사용할 수 있습니다.

  1. 시작»모든 프로그램»National Instruments»NI OPC Servers 2012»NI OPC Servers 구성을 선택하여 NI OPC Servers 2012를 시작합니다. NI OPC Servers 2012를 사용하면 PLC와 관련된 태그를 생성, 구성 및 볼 수 있습니다.
  2. NI OPC Servers 2012는 이미 로드된 PLC 시뮬레이션 프로젝트와 함께 실행됩니다. 이 프로젝트는 NI OPC Servers 2012에서 이미 생성 및 구성된 PLC를 시뮬레이션 합니다.

참고: 이 시뮬레이션 프로젝트가 아직 NI OPC Servers 2012에 로드되지 않은 경우, 파일»열기…를 선택하고 C:\Program Files\National Instruments\Shared\NI OPC Servers\V5\Projects\simdemo.opf를 찾습니다. 프로젝트는 그림 1과 같아야 합니다.


그림 1. 시뮬레이션된 PLC를 표시하는 NI OPC 서버 2012

  1. Simulation Examples를 확장하고 Functions를 선택하여 Sine 태그를 봅니다. 태그는 맨 오른쪽 창에 채워집니다. PLC의 레지스터에 바인딩된 이러한 태그는 LabVIEW에서 읽을 수 있습니다.
  2. PLC의 OPC 태그에서 데이터보기
    1. NI OPC Servers 2012에서 Tools>>Launch OPC Quick Client를 선택하여 Quick Client를 시작하십시오. 이를 사용하여 OPC 태그 데이터를 볼 수 있습니다.
    2. National Instruments.NIOPCServers.V5 폴더에서 Simulation Examples.Funtions를 선택하십시오. 모니터링할 장치를 선택합니다.
    3. 모든 사인 태그가 가장 오른쪽 창에 채워지고 그림 2에 표시된 것처럼 시뮬레이션 된 사인 데이터로 업데이트됩니다.
그림 2. 시뮬레이션 된 사인 OPC 태그를 표시하는 NI OPC 퀵 클라이언트

I/O Server를 생성하여 LabVIEW를 OPC 태그에 연결

이 섹션에서는 I/O Server라고 하는 OPC 태그에 대한 LabVIEW 인터페이스를 생성합니다. I/O 서버는 사용자가 지정한 속도로 현재 태그 값으로 LabVIEW를 자동으로 업데이트합니다.

  1. LabVIEW의 시작하기 창에서 파일≫새 프로젝트를 클릭합니다. 새로운 LabVIEW 프로젝트가 열립니다.
  2. 기본 도움말 창이 표시되지 않으면 Ctrl+H를 눌러 창을 표시하십시오. 커서 아래에 있는 항목에 대한 유용한 정보를 보려면 이 창을 열어 두십시오.
  3. LabVIEW 프로젝트 창에서 그림 3과 같이 내 컴퓨터를 마우스 오른쪽 버튼으로 클릭하고 새로 만들기»I/O Server를 선택합니다.
그림 3. LabVIEW 프로젝트를 통해 새로운 I/O Server 생성
  1. 새로운 I/O Server 생성 창에서 OPC Client를 선택하고 Continue를 클릭합니다.
  2. Registered OPC servers 필드에서 National Instruments.NIOPCServers.V5를 선택하고 업데이트 속도(ms)를 100으로 설정합니다. 그러면 LabVIEW에서 OPC 태그로의 연결이 생성되며 100ms마다 업데이트 됩니다.
그림 4. OPC Client I/O Server 구성
  1. 확인을 선택합니다. I/O Server를 관리하기 위해 프로젝트 탐색기 창에 라이브러리가 자동으로 생성됩니다.
  2. 프로젝트 탐색기 창에서 파일≫모두 저장을 선택하여 프로젝트를 OPCDemoProject로 저장하고 라이브러리를 OPCDemoLibrary로 저장합니다.

I/O Server를 통해 OPC 태그에 연결하는 공유 변수 생성

이 섹션에서는 OPC 태그에 바인딩된 공유 변수를 생성하여 LabVIEW에서 PLC 데이터에 대한 기본 액세스를 제공합니다. 공유 변수를 사용하면 단일 컴퓨터 또는 네트워크에서 LabVIEW 어플리케이션 간에 데이터를 공유할 수 있습니다.

  1. PLC의 OPC 태그에 바인딩된 새 공유 변수를 만듭니다.
    1. LabVIEW 프로젝트 창에서 내 컴퓨터를 오른쪽 클릭하고 새로 만들기»라이브러리를 선택합니다. 그러면 PLC의 OPC 태그에 연결하는 데 사용되는 공유 변수에 대한 새 라이브러리가 생성됩니다.
    2. 새로 생성된 라이브러리를 마우스 오른쪽 버튼으로 클릭하고 Create Bound Variables…를 선택합니다.
    3. Create Bound Variables 창에서 그림 5와 같이 OPC 서버에서 시뮬레이션 된 사인 데이터를 검색하여 공유 변수를 바인딩 할 OPC 태그를 선택합니다.
그림 5. 공유 변수에 바인딩할 OPC 태그 선택
  1. 모든 사인 항목을 선택하고 추가확인을 클릭합니다. 이렇게 하면 PLC의 OPC 태그에 바인딩된 공유 변수가 생성되어 다중 변수 편집기에 로드됩니다.
  2. 다중 변수 편집기에서 완료를 선택하십시오. 이렇게 하면 이전에 생성된 라이브러리에 새 공유 변수가 추가됩니다.

참고: LabVIEW DSC Module은 LabVIEW 어플리케이션을 작성하지 않고도 데이터, 알람 및 이벤트를 데이터베이스에 직접 기록하는 기능을 추가하여 공유 변수를 향상시킵니다.

  1. 라이브러리를 마우스 오른쪽 버튼으로 클릭하고 다른 이름으로 저장을 선택하여 새 라이브러리를 프로젝트 탐색기 창에 OPCItems.lvlib로 저장합니다.
  2. OPCItems 라이브러리를 마우스 오른쪽 버튼으로 클릭하고 배포를 선택하여 공유 변수를 배포합니다. 이렇게 하면 공유 변수가 게시되어 네트워크에서 다른 컴퓨터, OPC 클라이언트 및 LabVIEW Real-Time PAC에서 사용할 수 있습니다.

이제 공유 변수를 통해 LabVIEW에서 기본적으로 PLC 데이터에 액세스 할 수 있습니다.

분산 시스템 관리자로 공유 변수보기

  1. 프로젝트 탐색기 창에서 도구»분산 시스템 관리자를 선택합니다. 그러면 다양한 방법 (보기, 배포, 배포 취소 등)으로 공유 변수를 관리하는 데 사용할 수 있는 창이 열립니다.
  2. 변수 관리자의 트리 창에서 내 시스템 범주 아래의 localhost 항목을 확장합니다. OPCItems 라이브러리를 마우스 오른쪽 버튼으로 클릭하고 Watch List를 선택하여 PLC의 OPC 태그에 바인딩 된 공유 변수를 표시합니다.
  3. 공유 변수는 시뮬레이션된 사인 데이터로 업데이트됩니다.

참고: 분산 시스템 관리자는 LabVIEW 8.6의 새로운 기능입니다. 이전 버전의 LabVIEW는 도구≫ 공유 변수≫변수 관리자로 이동하여 공유 변수를 Watched Variables: 창으로 드래그 하여 이를 수행했습니다.

LabVIEW에서 OPC 태그 데이터 사용

  1. 프로젝트 탐색기에서 내 컴퓨터를 오른쪽 클릭하고 새로 만들기»VI를 선택합니다. 이것은 새로운 가상 계측기 또는 VI를 생성합니다. VI는 사용자 인터페이스와 실행 가능한 그래픽 코드를 생성하는 데 사용됩니다.
  2. 기본적으로 VI의 사용자 인터페이스 인 프런트 패널이 표시됩니다. LabVIEW에는 강력하고 직관적인 UI를 구축하는 데 사용할 수 있는 그래프, 차트, 다이얼 등과 같은 많은 내장 UI 구성 요소가 있습니다. 보기»컨트롤 팔레트를 선택하거나 프론트 패널의 아무 곳이나 마우스 오른쪽 버튼으로 클릭하여 컨트롤 팔레트를 불러옵니다. LabVIEW의 UI 구성 요소를 탐색하려면 다양한 범주 위로 마우스를 이동하십시오.
  3. Express»그래프 인디케이터»차트를 선택하여 컨트롤 팔레트에서 웨이브 폼 차트를 선택하고 그림 6과 같이 프런트 패널에 배치합니다.

그림 6. 컨트롤 팔레트에서 파형 차트 선택


그림 7. 프런트 패널에 배치된 파형 차트
  1. VI에서 Window»Show Block Diagram을 선택하거나 Ctrl+E를 눌러 블록 다이어그램을 표시합니다. 블록 다이어그램은 애플리케이션의 동작을 구축하는 곳입니다. 프런트 패널의 차트를 나타내는 블록 다이어그램의 아이콘을 확인하십시오. 이 터미널에 데이터를 전달하면 프론트 패널의 차트에 데이터를 표시할 수 있습니다.
  2. 프로젝트 탐색기에서 OPCItems 라이브러리를 확장하고 Sine1s hared 변수를 선택합니다.
  3. 프로젝트 탐색기에서 Sine1 공유 변수를 VI의 블록 다이어그램으로 끌어 놓습니다. 공유 변수는 블록 다이어그램의 다른 터미널에 대한 데이터 소스 역할을 합니다.
  4. 보기 ≫ 도구 팔레트를 선택하거나 Shift+오른쪽 클릭을 눌러 블록 다이어그램을 구축하기위한 다양한 도구를 포함하는 도구 팔레트를 표시합니다. 기본적으로 커서 위치에 따라 적절한 도구를 선택하는 자동 도구 선택 도구를 사용합니다.
  5. 그림 8과 같이 와이어 연결 도구를 선택합니다. 이 도구는 블록 다이어그램에서 터미널을 함께 연결하는 데 사용됩니다.

그림 8. 와이어 연결 도구 선택
  1. 그림 9에 도시된 바와 같이 Sine1이 변수를 공유하고 파형 차트에 Sine1 클릭하여 파형도에 변수를 공유 배선에 연결 와이어 도구를 사용한다.

터미널을 함께 배선

연결된 터미널
그림 9. 블록 다이어그램 항목 연결

이제 데이터는 VI가 실행 중일 때 공유 변수에서 웨이브 폼 차트로 흐릅니다.

  1. 도구 팔레트에서 자동 도구 선택 도구를 선택합니다.

그림 10. 도구 팔레트에서 자동 도구 선택
  1. 보기 ≫ 함수 팔레트를 선택하거나 블록 다이어그램의 아무 곳에서나 오른쪽 클릭하여 함수 팔레트를 엽니다. 함수 팔레트에는 그래픽 프로그래밍을 위한 수백 개의 분석 함수, 제어 함수 및 구조가 포함되어 있습니다.
  2. Programming≫Structures≫While Loop 로 이동하여 함수 팔레트에서 while 루프를 선택합니다. while 루프를 선택하면 그림 12와 같이 커서가 나타납니다. 이를 통해 코드 섹션 주위에 while 루프를 감쌀 수 있습니다.

그림 11. While 루프 선택

그림 12. While 루프 커서
  1. while 루프 커서를 사용하여 커서를 클릭하고 끌어서 공유 변수 및 파형 차트 주위에 while 루프를 배치합니다. 이제 루프 조건을 마우스 오른쪽 버튼으로 클릭하고 컨트롤 만들기를 선택하여 while 루프에서 중지 컨트롤을 만듭니다. 그러면 사용자가 VI를 중지할 수 있는 중지 버튼이 프런트 패널에 배치됩니다.


그림 13. 공유 변수 및 파형 차트 주위에 While 루프 배치

while 루프는 사용자 또는 VI의 추가 로직에 의해 중지될 때까지 그 안의 코드가 계속 실행되도록 합니다.
 
  1. while 루프가 현재이므로 가능한 한 빨리 실행됩니다. 다음 ms 배수까지 기다림 VI를 루프에 추가하여 루프가 설정된 시간 (이 경우 100ms)마다 실행되도록해야 합니다.

그림 14. While 루프에 타이밍 추가
  1. 창≫프런트 패널 표시를 선택하거나 Ctrl+E를 눌러 프런트 패널로 돌아갑니다.
  2. 도구 모음에서 실행 버튼을 클릭하여 VI를 실행합니다.

그림 17. 실행 버튼
  1. 배포가 완료되면 배포… 창에서 닫기를 클릭합니다. 애플리케이션이 실행되기 시작하면 파형 차트에 Sine1 사인파가 표시됩니다.

그림 18. 완성된 프런트 패널 – 파형 차트에 PLC 데이터 표시

축하합니다! LabVIEW 어플리케이션에서 PLC 데이터에 성공적으로 접근했으므로 솔루션에 강력한 분석 및 제어 기능을 통합 할 수 있습니다.