Could Not Find Product Error When Installing NI Software

Updated Mar 3, 2021

Reported In

Software

  • Academic Site License
  • Multi-IDE Bundle
  • Software Platform Bundle
  • LabVIEW 2020 SP1
  • Package Manager

Issue Details

When trying to install NI Software, I received the following error in NI Package Manager (NIPM): 

"Could not find product 'ni-XXXX-XXXX'."

image.png

Solution

This behavior may be caused by intermittent network issues. It is most commonly seen with (but not limited to) the following NI software suites: Academic Site License for LabVIEW, Multi-IDE Bundle, Software Platform Bundle, and LabVIEW 2020 SP1 and Drivers.

To proceed with installing your software, try the following steps to address or avoid these connectivity issues:
  • Make sure you have a stable network connection.
    1. Try installing the product again through NIPM using the same network. 
    2. If available, try connecting to a different network.
  • If you are downloading the software package from ni.com using a web browser, clear cache and cookies from your browser. Then try downloading the software package again.
  • Install the software using the offline installer.
    • If you have tried on all networks available and the error persists, use an offline installer to download the .iso package. This process should help to overcome the error if the root cause is network issues within NI Package Manager.