在NI MAX中格式化Linux RT目标时出现错误-2147220385或-2147220289

更新 Jul 15, 2020

适用于

软件

  • Measurement & Automation Explorer (MAX)

操作系统

  • LabVIEW Real-Time (NI Linux Real-Time)

问题详述

当我在与进行镜像文件交互或更改镜像文件时,会出现错误-2147220385或-2147220289:
  • 使用NI Measurement and Automation Explorer(NI MAX)格式化我的Linux Real-Time目标
  • 使用LabVIEW Real-Time软件向导更改基本系统映像
  • 使用LabVIEW Real-Time软件向导更改编程环境
  • 使用RAD获取或设置系统映像
-2147220385 NISysCfg_HostSoftwareTooOld
目标需要计算机上软件不支持的较新功能。将NI系统配置更新到最新版本以配置该目标。有关更多信息,请参见www.ni.com/r/rtconfigerror。

-2147220289 NISysCfg_不支持的CDF版本
  • 目标上安装的软件使用计算机上的软件不支持的CDF格式。将NI系统配置或NI MAX更新至最新版本以配置该目标。
  • 安装的目标软件与此版本的Measurement&Automation Explorer不兼容。请为此目标使用最新版本。另外,如果您格式化目标,也可以继续。
  • 不支持的CDF格式版本。需要更新版本的MAX或NI System Configuration。

解决方案

当目标上的基础系统映像比用于格式化目标的NI MAX(或系统配置API)版本高时,会发生此错误。

要解决该问题,请使用NI Package Manager在主机上安装最新版本的System Configuration驱动,其中包括NI MAX和System Configuration API。