LabVIEWでライブラリファイル(LLB)を作成するにはどうすればよいですか?

更新しました Feb 20, 2024

環境

ソフトウェア

  • LabVIEW Full

新規または既存の VI から新しいLLBファイルを作成するにはどうすればよいですか。この資料ではLLBファイルを作成する方法およびLLBファイルにVIを保存する方法を紹介します。

  1. プロジェクトエクスプローラーウィンドウからLLBを作成する方法
LabVIEW 8.5以降:
  1.  新しいプロジェクトを作成するか、既存のプロジェクトを開きます。
ブロックダイアグラムまたはフロントパネルから新しいプロジェクトを作成するには、 ファイル>>新規>>プロジェクト>>空のプロジェクトを選択してOKをクリックします。 LabVIEW入門画面から新しいプロジェクトを作成するには、ブランクプロジェクトを選択します。
       project.PNG
  1. マイコンピュータを右クリックし、新規>>VIを選択し、VIをプロジェクトに追加します。
  1. ビルド仕様を右クリックして、新規>>ソース配布を選択します。
      build.PNG
  1.  マイソース配布プロパティ ウィンドウのソース ファイルカテゴリに移動します。
  2. プロジェクトファイルウィンドウから VI を選択し、右矢印ボタンをクリックして、常に含むボックスに移動させます。(その VI を LLB ビルドに含めます)
      alwaysinclude.PNG
  1.  出力先カテゴリに移動ソして、真ん中側にあるカテゴリ リストで出力先出力ディレクトリを選択します。
  2. 出力先タイプ としてLLBを選択して、ビルドをクリックします。
 
       output.PNG

 
LabVIEW 8.0および8.2の場合:
  1. プロジェクトエクスプローラーウィンドウから、ビルド仕様>>新規>>ソース配布を右クリックします。
     
  1.  カスタムをクリックします。
  2.  出力は LLBにチェックをいれて、ポップアップ ウィンドウではいをクリックします。
     
  1.  ビルドをクリックします。
 
  1. 既存の VI を新しい LLB ファイルに配置する別の方法は次のとおりです。
    1.  新しいLLBに配置したいVIのファイルメニューから名で保存を選択します。
    2. 「 元のファイルを閉じてコピーを編集する」を選択し、 継続ボタンをクリックします。(作成したコピーを編集し、元のファイルは閉じられます)
    3. 新しいLLBを保存されたい場所を選択し、右下の新しいLLBボタンをクリックします。
 
     newllb.PNG
  1. ポップアップウィンドウで新しいLLBファイルに名前をつけて、作成をクリックします。
    newllb2.PNG
  1. VIに別名をつけて、OKのクリックにて新しく作成されたLLBファイル内にVIを保存します。
    saveVIin new LLB.PNG

新規作成されたLLBファイルを開くと、VIか配置されていることが確認できます。

   savedVIin new LLB.PNG

 
  1. 新しいVIを作成して新しいLLBに保存するには、空のVIを開いてファイルメニューから保存を選択し、ステップ3~5に従ってください。

    注:この方法では、LLB にサブ VI が自動的に組み込まれません。 LLB に依存要素を含める必要がある場合は、次の記事の手順に従ってください: すべてのサブVIを自動的に含むLabVIEW VIライブラリを作成するにはどうすればよいですか?
 
  1. LLB を編集する別の方法は、LLB マネージャ (LabVIEW 8.5 以降) を使用することです。
 
  1.   メニューのツール>>LLBマネージャーに移動します。
llbmanager.PNG
  1. 新しい LLB を保存するフォルダーに移動します。
   llbmanager2.PNG
  1. 新しい LLBを作成アイコン選択し、LLB の名前を設定します。
 
llbmanager3.PNG
  1.  作成したLLBにVIを追加するには、VIに移動し、 LLBマネージャからVIをコピーします。
  2. LLBファイルに移動して開き、VIを貼り付けます。