在NI Ultiboard中创建自定义组件

更新 Jul 22, 2022

环境

软件

  • Ultiboard

NI MultisimNI Ultiboard提供了一个集成平台,用于设计,仿真和布局完整的印刷电路板(PCB)。高度灵活的数据库管理器使您可以轻松地将新的SPICE仿真模型添加到自定义定义的原理图符号中,然后可以将准确的封装图传输到布局中。 Multisim中的原理图符号与转移到布局的Ultiboard格局相关。这两个教程构成了一个完整的从A到Z的组件创建指南,从原理图符号和仿真模型到最终的PCB设计图。

在NI Multisim中创建自定义组件和在NI Ultiboard创建自定义组件是您如何直观,快速地学习如何创建自己的自定义组件的资源。第1部分介绍了如何利用组件向导创建具有原理图符号和SPICE仿真模型的自定义组件。在这一部分中,预定义的数据库覆盖区或格局与新创建的组件相关联。

本教程(第2部分)概述了如何创建自定义的Ultiboard布局模式以进行布局。该平台是手动创建的,以便精确定义表面贴装设备(SMD)的形状,大小和尺寸。本文将概述创建可与创建的自定义组件关联的自定义20针SMD平台的步骤。在NI Multisim教程中创建自定义组件中

创建过程中的步骤包括:

  • 创建数据库组
  • 定义自定义PCB零件
  • 设置环境网格间距
  • 放置SMD焊盘图案焊盘
  • 设置参考ID和值
  • 使用标尺进行对象定位
  • 定义IC封装
  • 创建3D模型
  • 将Landpattern保存到Ultiboard和Multisim数据库
  • 将格局与Multisim符号关联

请注意:在本教程中创建的Landpattern不是商业软件包。垫和包装的尺寸以及间距主要用于展示Ultiboard中有效的设计程序。

在本教程中,术语格局足迹将互换使用。

创建数据库组

Ultiboard和Multisim都共享一个通用的数据库结构,该结构将各个组件组织成逻辑组。因此,创建任务在Ultiboard数据库管理器中开始。

  1. 选择工具>>数据库>>数据库管理器以显示数据库管理器(图1)。

图1-数据库管理器

 

  1. 在数据库管理器中,选择用户数据库(上图1中的红色正方形)。
可以在数据库管理器中创建自定义组,以逻辑方式组织存储位置。不必为每个新组件都创建数据库组。创建组是为了帮助适当地组织数据库。如果已经创建了一个可以将自定义组件保存到的组,则可以直接跳到e
  1. 选择新建数据库组图标(上图1中的黄色正方形)。
  2. 将出现一个新的分支,以表示用户数据库根目录中的一个组。输入组名称Custom SMD
  3. 选择创建新零件图标(上图1中的蓝色正方形)。 NI Ultiboard将显示一个对话框,显示要创建的组件类型的选项,如图2所示。

图2-选择零件

 

  1. 在图2所示的对话框中选择PCB部件选项。

Ultiboard设计区域现在将处于足迹编辑模式,并显示x ??。符号(图3)。 X?代表参考标记(RefDes)和?表示组件的值。这些值将在设计过程的稍后步骤4中进行编辑。

 

图3-足迹编辑模式

 

编辑网格间距

重要的是通过设置地形图案设计网格的度量单位来开始设计过程。在放置零部件时,设计网格是对象在移动和/或放置时将捕捉的对象。因此,网格间距定义了可将对象放置在工作区域中的精确度。

  1. 选择选项>> PCB属性。
  2. 单击网格和单位选项卡。

图4-网格属性

 

  1. 在单位部分(图4)中,将设计单位设置为mil。
  2. 要设置各种Ultiboard设计网,请在Grid Step Name组合框(图4中的红色框)中选择Component Grid
  3. 网格步长值设置为1 mil
  4. 网格步骤名称组合框中选择铜质网格。
  5. 网格步长值设置为1 mil

通过这些设置,元件和铜都将放置在1 mil x 1 mil设计网格上。

 

放置格局图钉

THT(通孔技术)引脚和SMD(表面安装器件)焊盘均可放置在自定义焊盘图案上。以下步骤将概述如何添加SMD焊盘阵列。

  1. 选择位置>>引脚。这将显示放置引脚对话框(图5)。

图5-引脚属性对话框

现在,您将为我们的自定义焊盘图案定义10 x 2的SMD引脚阵列。

  1. 选择SMD引脚单选按钮。以下值(例如,顶部,引脚长度,引脚宽度和引脚半径)定义每个引脚的形状和物理尺寸。在表1中设置以下值以定义引脚属性(如图6所示);

表1:引脚尺寸

栏位名称

 

栏位说明

最佳

圆角矩形

顶部字段描述了垫的形状。其他选项包括圆形,矩形等。

针长

58.34

插针长度定义了插针的垂直尺寸

针脚宽度

15

插针宽度定义了插针的水平尺寸

Pin Radius

7.5

对于圆形物体,销钉半径定义物体圆形部分的半径

 

图6-设置SMD引脚属性

 

  1. 现在,您将创建10 by 2 SMD引脚阵列以放置在焊盘图案上。现在将设置的垂直和水平间距表示相邻插针之间的中心距。在表2中设置以下间距值。对话框应如图7所示。
  2. 单击确定按钮以将焊盘放置到焊盘图案上

表2:引脚间距

栏位名称

 

栏位说明

垂直

25

相邻引脚之间的中心到中心垂直间距。

卧式

200

相邻引脚之间的中心到中心水平间距。

行数

10

引脚阵列中的行数

2

引脚阵列中的列数

注意:可以更改上述对话框设置以适合您的特定格局。例如,如果都设置为1 ,则可以放置单独的引脚。

图7-设置SMD引脚间距

针脚阵列的针脚1是左上角的焊盘,并固定在鼠标光标上。要准确放置打击垫,使参考点位于打击垫中间,请按右侧数字键盘上的星号键(*) (不按Shift + 8)。笔记本电脑用户必须按FN + 0

Ultiboard工作区现在将如图8所示。您将注意到我们的销钉方向不正确(垂直而不是水平),并且必须旋转90度。

图8-引脚设置

  1. 选择工具栏中,单击启用选择SMD焊盘图标,如图9所示。

图9-选择工具箱(SMD垫)

 

  1. 在设计区域上拖动鼠标以创建一个选择框,该选择框将选择所有SMD引脚
  2. 双击选定的引脚之一。将出现SMT引脚属性对话框。选择常规选项卡。
  3. 选择角度(度)组合框,并将其设置为90度(如图10中的红色框所示)。单击确定按钮以保存更改。您会注意到SMD引脚已经旋转,现在看起来如图11所示。

图10-销角

图11-最终SMD引脚方向

 

更改引脚名称和值

在创建新的焊盘图形期间,可以以随机顺序将销钉放置到设计上。因此,可能有必要编辑与每个引脚相关的值,以使它们在封装周围依次编号。

  1. 选择工具栏中,单击启用选择SMD焊盘图标,如图9所示。
  2. 双击右下角的图钉。将出现SMT引脚属性对话框。选择属性选项卡。
  3. 属性列表(图12)显示了一个标签,该标签存储了插针编号( NUMBER ),插针值( 20 )及其可见性( None )。
  4. 在属性列表中选择NUMBER标签,这将激活Change按钮(图12中的红色框)。单击更改按钮。

图12-SMD引脚属性

  1. 在属性对话框中,更改字段(图13中的红色框)将更改引脚的值。

图13-SMD引脚属性

 

通常,诸如此类的包装具有沿逆时针方向顺序编号的销。因此,插针10应该在左下角,插针11应该在右下角此设计的最终引脚号配置应如图14所示。

  1. 字段更改为11,然后单击确定按钮。单击SMT引脚属性对话框中的确定按钮以保存更改。
  2. 重复4 ,5和6 用于所需配置的所有引脚(如图14所示)。

图14-组件引脚设置图

 

设置参考ID和值的位置

在图11中,您将继续注意到x ??。符号,代表参考标志和土地格局的价值。

参考指示符是组件的关键标识符,用x?表示 。可以更改此x ,使其与关联的组件类型相对应。例如,如果此焊盘图案是为一电阻该值可以被设置为R的代表一个数字,表示设计中的不同组件。因此,以电阻器为例,将放置在设计上的电阻器命名为R1,R2,R3等…

价值,由?符号,是组件的物理值。再次以电阻器为例,等于20k等于20k

在此步骤中,您将选择,移动和更改RefDes和值。

  1. 选择工具箱中,单击启用选择属性图标,如图15所示(在红色框中)。这将使您可以将地形图上的零部件选择缩小为仅RefDes和Value属性。

图15-选择工具箱(选择属性)

 

RefDes和Value当前与地形图案放置重叠,如图11所示。

  1. 单击X?符号并将其放置在填充阵列的右上角。
  2. 点击符号并将其放置在填充阵列的右上角。
  3. 双击X?然后选择属性标签
  4. 字段中,将REFDES标记设置为U?如图16(在红色框中)
  5. 单击确定以应用更改。

图16-REFDES属性属性

 

现在放置自定义组件时,用于地形图的RefDes将为U1,U2,U3等。

通常,根据需要在最终设计上突出显示格局的值,将Value属性(?)设置为可见或不可见。在此示例中,它将设置为不可见。

  1. 双击X?然后选择属性标签
  2. 在属性的“可见性”部分中,设置“不可见”单选按钮

 

使用标尺栏

Ultiboard设计区域的顶部和左侧都是图11中的标尺。如果看不到标尺,请转到查看>>标尺。这些标尺允许将虚线定位,以在设计区域内精确地将一个对象与另一个对象的形状对齐。有关以下步骤,请参见图14的引脚号。

  1. 在水平(顶部)标尺栏区域中单击鼠标左键,将出现一个小的箭头标记,并将标记立即移到针1的右侧(图17)。
  2. 左键单击以放置一个标记,距离放置在a中的标记右侧5密耳。您会注意到,两个标记之间的距离显示在标尺栏中(图17)
  3. 在垂直(左)标尺栏上,在针1上方直接放置另一个标记(图17)
  4. 重复1.,2。和3。在SMD焊盘阵列的右侧和底部对齐标尺标记,如图17所示。

图17-标尺条

 

这些标记现在将作为步骤7中丝印层上焊盘图案开始位置的指导。

如果在任何时候都需要清除标记,则可以右键单击特定的标记并选择“清除”,或者选择“全部清除”以删除所有标记。

 

将Landpattern图形放置在丝印上

丝印层上形状的位置定义了自定义组件在设计中的显示方式。它代表包装的物理尺寸。在这一步中,您将利用在第4步中设置的标尺标记来放置矩形地形图案形状。

  1. 在Design Toolbox(图18)中,双击Silkscreen Top,以使该特定层处于活动状态。这将以红色突出显示该层。

图18-设计工具箱

 

  1. 选择位置>>形状>>矩形。
  2. 现在处于绘制模式的Ultiboard准备绘制矩形。将鼠标对准左上角(距离图钉1针5密耳,如图16中的标尺标记所示)。
  3. 左键单击并拖动鼠标,在图11的内部矩形内绘制一个矩形。
  4. 矩形将显示为实心填充形状。单击选择工具栏中的启用选择其他对象图标(图19),然后双击实心矩形。

图19-选择工具箱(选择其他对象)

 

  1. 矩形属性对话框中,选择常规选项卡。在区域部分中,单击样式按钮,将黑色矩形更改为矩形轮廓,如图20(红色框)所示。单击确定按钮。

图20-矩形属性

 

现在将显示格局,如图21所示。

图21-最终格局

 

创建3D格局

在Ultiboard中,可以以3D预览设计以虚拟表示最终设计。为了为此3D预览设置自定义图案,应在创建阶段设置必要的信息。

  1. 在Design Toolbox(图18)中,双击Silkscreen Top,以使该层处于活动状态。这将以红色突出显示该层。
  2. 单击选择工具栏中的“启用选择其他对象”图标(图19),然后右键单击矩形包形状。在弹出菜单中选择复制
  3. 选择编辑>>粘贴,然后将重影的图像放置在地形图右侧的Ultiboard工作区上。
  4. 双击复制的矩形,然后在矩形属性对话框中选择位置选项卡。
  5. 在Layer组合框中,选择3D-info Top选项,如图22所示。单击OK。

图22-3D矩形属性

 

  1. 您可能会注意到,复制的3D框现在与3D层(当前不是活动层)关联时消失了。要再次查看该矩形,请双击设计工具箱中3D-InfoTop图层以将其激活。 3D矩形将显示为红色。
  2. 选择3D信息矩形并将其移动,使其直接位于原始丝网形状的顶部。
  3. 双击黑色工作区,然后选择3D数据标签
  4. 设置3D信息的属性(表3),对话框将如图23所示(在红色框中)。单击确定按钮。


表3:3D信息

栏位名称

 

栏位说明

为该对象启用3D

已检查

使Ultiboard渲染3D对象

高度

45.27555

3D对象的高度(以密耳为单位)

抵消

1.96850

离板的偏移高度

使用2D数据创建3D形状

已检查

在丝印层上使用2D形状创建包装形状

实心形状

已选

创建实体3D表示

图23-3D设置

 

  1. 3D数据标签中,选择引脚部分
  2. 如表4所示设置3D Pin信息的属性。单击OK按钮。


表4:3D引脚

栏位名称

 

栏位说明

垫角

90

设置Ultiboard相对于封装的插针连接角度。

针形

已检查

定义3D引脚的形状

类型

贴片

呈现特定类型的图钉

 

在3D预览中,您应立即注意到组件左侧的销钉背对包装。这是因为默认情况下,水平SMD引脚上的引线将指向左侧。因此,必须通过将销旋转180度来将销重新对准包装。

  1. 选择工具栏中,单击启用选择SMD焊盘图标,如图9所示。
  2. 按住CTRL键,然后在焊盘图上选择右列的图钉
  3. 双击选定的打击垫之一。
  4. 在 SMT引脚属性对话框中,选择常规选项卡

 

回想一下,在第3步中,将销设置为90度以用于水平方向。

由于旋转了90度,因此在上述步骤中,我们必须再旋转180度,以便3D引线现在指向组件。 90 + 180 = 270度。

  1. 角度(度)组合框中,将角度设置为270
  2. 单击确定按钮。

如果双击黑色工作区域并选择3D数据选项卡,您会注意到,如图24所示,引脚相对于3D封装正确放置。

图24-3D引脚设置

 

 

保存格局

创建了格局后,剩下的全部保存到Ultiboard数据库中。

  1. 选择文件>>保存到数据库。
  2. 在数据库部分中,选择在步骤1中创建的Custom SMD组(图25中的蓝色框)。
  3. 将组件SMD20命名为图20(红色框)。
  4. 单击确定按钮。

图25-“保存”对话框

 

将Landpattern添加到Multisim数据库

在Multisim中可以使用自定义环境模式之前,必须将其添加到数据库中。一旦添加到数据库,就可以将其视为可用的格局或覆盖区,并添加到组件中。

在此步骤中,创建的SMD20教程环境格局将与在教程的第1部分中创建的符号相关联。如果尚未创建自定义Multisim组件,请单击此处查看教程的第1部分。

  1. 打开NI Multisim。
  2. 选择工具>>数据库>>数据库管理器。
  3. 在数据库管理器中选择组件 标签。在数据库名称下,选择用户数据库
  4. 组件列表中,选择THS7001组件,然后单击编辑按钮。
  5. 组件属性对话框中,单击“足迹”选项卡。
  6. 单击从数据库添加按钮。
  7. 选择足迹对话框中,选择用户数据库 (图22中的红色框)。您会注意到,当前用户数据库看不到在本教程的步骤1至9中创建的格局。
  8. 要添加格局,请单击Add按钮(图26中的蓝色框)。

 

图26-Multisim数据库管理器

 

  1. 添加足迹对话框中,设置以下数据,如表5所示。该对话框将如图27所示(红色框)。

表5:添加足迹

栏位名称

 

栏位说明

数据库名称

用户数据库

在Ultiboard中保存了格局的数据库

制造商

泛型

附加的制造商标识符

脚印

贴片20

这是一个CASE SENSITIVE字段,并且必须准确地标识保存在Ultiboard中的格局

Ultiboard足迹

贴片20

这是一个区分大小写的字段。当“封装”字段标识组件的特定封装名称时,它可以与“ Ultiboard封装”相关联,以便可以将具有相同尺寸的通用封装转移到布局中

针数

20

焊盘图案上的引脚数

SMT / TH

贴片机

引脚技术的类型表面安装或通孔

 

图27-添加足迹

  1. 单击确定按钮。
  2. 您会注意到,现在可以在对话框中预览SMD20。单击选择按钮以选择新添加的SMD。
  3. 单击确定按钮以保存组件设置。
  4. 将组件保存到适当的数据库和组(与最初保存到的数据库相同),然后单击确定按钮。系统将提示您覆盖原始组件。选择按钮。

 

成功!!您已经创建了自定义的Ultiboard格局,定义了3D模型并将其关联到Multisim符号。