在NI Multisim中创建自定义组件

更新 May 6, 2021

环境

软件

  • Multisim

NI MultisimNI Ultiboard提供了一个集成平台,用于设计,仿真和布局完整的印刷电路板(PCB)。高度灵活的数据库管理器使您可以轻松地将新的SPICE仿真模型添加到自定义的原理图符号中,然后可以将准确的封装图传输到布局中。

在NI Multisim中创建自定义组件和在NI Ultiboard创建自定义组件是您如何直观,快速地学习如何创建自己的自定义组件的资源。

1.简介

本教程是有关在NI Multisim和NI Ultiboard中创建组件的系列文章中的第一篇。

本教程的目的是说明如何在Multisim中创建自己的用于仿真和/或印刷电路板(PCB)布局的组件。您将创建组件,然后验证其操作。组件向导是用于在Multisim中创建自定义组件的主要工具,它引导您完成创建新组件所需的所有步骤。组件详细信息包括符号以及(可选)引脚,型号和封装信息。创建过程中的步骤包括:

  • 输入组件信息。
  • 选择封装和组件配置。
  • 选择和/或编辑组件符号。
  • 设置引脚参数。
  • 将符号引脚映射到占位引脚。
  • 选择仿真模型。
  • 将符号引脚映射到模型引脚。
  • 将零件保存在数据库中。

本教程将指导您完成在Multisim中创建仿真和PCB布局兼容组件的过程。为了完整起见,您将学习如何创建一个包含两个部分的高级组件。您将创建具有两个原理图符号,两个模型但只有一个封装的零件。许多组件更易于创建,并且在大多数情况下并不需要概述的所有步骤。 Multisim还允许用户创建仅模拟或仅布局的组件。

组件创建文章的第2部分标题为“在NI Ultiboard中创建自定义组件” ,概述了如何为布局创建自定义Ultiboard格局。手动创建此格局,以精确定义表面贴装设备(SMD)的形状,大小和尺寸。可以将此足迹添加到Multisim数据库中以定义自定义组件。

单节与多节组件

单节组件是每个芯片具有单个设备的组件。多节组件是每个芯片具有多个门或器件的组件。多节器件的示例包括逻辑门或运算放大器。按照字母从A-Z的顺序列举了多部分组件中的设备。

纯仿真组件

纯仿真组件旨在帮助验证设计;它们不会转移到电路板布局。没有与之关联的足迹信息,并且在Multisim环境中,默认情况下,其符号被涂成黑色,以便于识别。纯仿真组件的一个示例是理想电压源。

仅布局的组件

仅布局的组件对模拟没有帮助。它们没有关联的SPICE或行为模型。当与电路并联时,它们对仿真没有影响。当串联连接时,它们将产生开路。仅布局的组件在Multisim环境中为绿色。连接器是仅布局组件的一个示例。

在NI Multisim中创建德州仪器(TI)THS7001组件

德州仪器(TI)THS7001是一个多部分组件的示例。该组件具有一个可编程增益放大器(PGA),具有一个集成在单个集成电路(IC)封装中的单独的前置放大级。在该封装中,两个部分共享电源和参考电压连接。可编程增益通过三个TTL兼容输入进行数字控制。有关此组件的更多详细信息,请参阅“下载”部分中的文件datasheet_ths7001.pdf

在接下来的步骤中,您将学习如何使用组件向导在Multisim中创建THS7001。

 

2.步骤1:输入初始组件信息

  1. 从Multisim主菜单中选择“工具”»“组件向导”。将打开“组件向导”窗口。
  2. 如下图所示配置此窗口。

图1. THS7001组件信息。

  1. 单击下一步继续。

 

3.步骤2:输入封装和封装信息

在此步骤中,您将输入Footprint信息。根据数据表,该组件使用HTSSOP-20 PowerPAD(PWP)占位面积。您将从Multisim Master数据库中选择此封装。

  1. 单击选择Footprint按钮。将打开“选择Footprint”窗口。
  2. 数据库名称列表框中选择主数据库
  3. 点击过滤器。这有助于您在成千上万个足迹中进行快速搜索。
  4. 单击添加行按钮。
  5. 配置Filter窗口,如图2所示。

图2.过滤足迹。

  1. 单击确定。 “选择足迹”窗口将显示足迹列表,如下图所示。

图3.选择HTSSOP-20(PWP)封装。

  1. 突出显示占位HTSSOP-20(PWP) ,然后单击“选择”

注意:要了解如何在NI Ultiboard中创建自定义封装,请查看《在NI Ultiboard中创建自定义组件》教程。

现在,您需要定义组件中的部分和引脚的数量。在这种情况下,有两个部分: A是前置放大器部分,它包含7个引脚。 B是可编程增益放大器部分,包含12个引脚。

  1. 配置多节参数,如图4a和4b所示。

(一种)

(b)

图4.多节参数。

注意:创建多部分组件时,引脚数必须与将用于该部分符号的引脚数匹配,而不是占位面积的引脚数。对于THS7001,您将在这两个部分的符号中添加接地引脚和节点关闭引脚。

  1. 单击下一步继续。

 

4.步骤3:输入符号信息

在定义了部分并选择了覆盖区之后,为每个部分分配符号信息。组件向导会生成一个默认符号,但是,您可以在符号编辑器中编辑该符号,或者从“原始数据库”中复制一个现有符号。为了节省创建定制零件的时间,建议您尽可能从Multisim数据库复制现有符号。您也可以将符号文件加载到符号编辑器中

  1. 单击编辑按钮。将打开“符号编辑器”
  2. 选择文件»打开,然后选择文件pre_amp.sym,可以在下载部分找到该文件。符号编辑器将为前置放大器加载符号,如下图所示:

图5.符号编辑器。

  1. 选择文件»退出以关闭符号编辑器,如果要求保存更改,请选择。现在,前置放大器符号将显示在预览框中(图6)。

如果您打算与世界各地的同事共享此组件,则最好为该设备创建ANSI和DIN符号。在这种情况下,只需单击“复制到”按钮,然后选择“ A部分(DIN)”

图6.前置放大器符号。

为可编程增益放大器部分分配一个符号:

  1. 在“Section”字段中选择B。
  2. 单击编辑以打开符号编辑器
  3. 打开“下载”部分中的文件pg_amp.sym
  4. 选择文件»退出以关闭符号编辑器,如果要求保存更改,请选择。现在,前置放大器符号将显示在预览框中,如下所示:

图7.可编程增益放大器符号。

  1. 单击下一步继续。

 

5.步骤4:设置引脚参数

在此步骤中,您可以为符号中的每个引脚选择引脚模型类型(输入,输出等)。您还可以配置是否在电气规则检查(ERC)中包括或排除该引脚。如果需要,您可以在此步骤中向组件添加隐藏的引脚。隐藏的引脚是没有出现在符号上的引脚,但可能由模型和/或封装使用。

  1. 配置“Section”和“Type”列,如下图所示:

图8.引脚参数。

  1. 单击下一步继续。

 

6.步骤5:设置符号和布局足迹之间的映射信息

将可见的符号引脚和隐藏的引脚映射到PCB足迹。通过将其与数据表信息进行比较,确保映射是准确的。

注意:仅仿真零件不需要此步骤。

  1. 单击每行对应的“Footprint pins”单元格,然后分配一个Pin号。配置的窗口将如图9所示。请注意,引脚1和17共享引脚。

图9.符号和布局之间的映射信息。

  1. 单击下一步继续。

 

7.步骤6:选择仿真模型

创建用于仿真的组件时,必须为每个部分提供仿真模型。您可以通过四种方式获取或创建新模型:

  • 从制造商网站或其他来源下载SPICE模型。
  • 手动创建子电路或原始模型。
  • 使用Multisim模型制作器。
  • 或编辑现有模型。

Multisim提供了可以根据其数据手册值为几种类别的组件创建SPICE模型的模型创建者。现有模型制造商用于运算放大器,双极结型晶体管,二极管,波导等。有关各种模型制作器的更多信息,请参考Multisim帮助文件。

对于THS7001,您将使用制造商提供的SPICE兼容型号。前置放大器和可编程增益放大器部分有不同的型号。它们可以在“下载”部分中找到。

注意:如果要创建仅布局的组件,则不需要完成步骤6和7。

  1. 在“Section”字段中选择“ A”选项卡。
  2. 单击从文件加载
  3. 打开“下载”部分中的文件ths7001_preamp.cir。前置放大器的SPICE模型将加载并显示在A部分的选项卡中,如下所示:

图10.前置放大器部分的SPICE模型。

  1. 在“Section”字段中选择“ B”选项卡。
  2. 单击从文件加载
  3. 打开“下载”部分中的文件ths7001_pga.cir。将加载用于可编程增益放大器的SPICE模型。
  4. 单击下一步继续。

 

8.步骤7:将符号引脚映射到模型节点

您必须将符号引脚映射到SPICE模型节点,以使Multisim正确模拟组件。对于所有子电路或宏模型,模型节点通常记录在SPICE模型的标题文本中。还有一行声明模型是子电路模型,并列出模型名称,后跟将要连接到外部电路的模型节点。

对于THS7001,前置放大器和可编程增益放大器的模型节点分别列在文件ths7001_pga.cir和ths7001_pga.cir中。您可以在文本编辑器中打开这些文件。

让我们检查一下前置放大器的插头和子电路(SUBCKT)线:

.SUBCKT行声明该模型是子电路模型,列出该模型的名称,并显示外部节点。注释行(SHUTDOWN,OUTPUT等)描述了模型节点的顺序和操作。

  1. 如图11所示,完成前置放大器的引脚映射表(A部分)。您必须根据它们在SUBCKT行中出现的顺序选择模型节点

图11. A部分引脚映射表。

  1. 选择B节,并根据下图填写引脚映射表:

图12. B部分引脚映射表。

  1. 单击下一步继续。

 

9.步骤8:将组件保存到数据库中

完成上述所有步骤后,将组件保存到UserCorporate Database中

  1. 展开用户数据库
  2. 选择模拟组。
  3. 单击“添加系列”,然后键入“放大器”作为新的系列名称。
  4. 单击确定
  5. 突出显示新的放大器系列,如下所示:

图13.将组件保存到数据库。

  1. 单击完成,然后将自定义组件(A和B节)放在Multisim工作区上。

图14. THS7001的A和B部分。

 

10.在Multisim中测试新组件

创建并保存自定义组件后,即可在Multisim中使用它。要测试此组件,请使用“下载”部分中的test_circuit.ms11文件。将U2A替换为新组件的A部分,并将U2B替换为B部分。要替换组件,请双击该组件,然后选择“替换” 。然后导航到保存组件的数据库和位置,然后选择它。

图15说明了测试电路的预期响应。

图15.增益设置为111的PGA的时域响应。