Arduino 펌웨어 용 LabVIEW 인터페이스를 Arduino Uno에 어떻게 로드합니까?

업데이트 됨 May 20, 2021

환경

소프트웨어

  • Third Party Add-Ons
  • LabVIEW

Arduino Uno용 LabVIEW 인터페이스를 사용하고 싶습니다. Arduino 펌웨어를 Arduino Uno에 어떻게 로드합니까?

참고: LIFA (LabVIEW Interface for Arduino) 패키지는 LINX로 대체되었습니다. LIFA에 대한 추가 개발이 없을 것이므로 LINX로 마이그레이션하는 것이 좋습니다. 자세한 내용은 LabVIEW 용 Digilent LINX를 다운로드하는 방법을 참조하십시오.


다음 지침은 보관되며 마지막 테스트는 Arduino 1.0.5 소프트웨어를 사용하여 수행되었습니다.

Arduino Uno를 내 PC에 연결하려면 어떻게합니까?에 설명된 대로 Arduino Uno를 PC에 연결하십시오.
  1. VIPM을 사용하여 LabVIEW Interface for Arduino Toolkit을 어떻게 설치합니까?에 설명 된 대로 LabVIEW Interface for Arduino 툴킷을 설치하십시오.
  2. 1단계에서 추출한 폴더를 찾아 arduino.exe를 두 번 클릭하여 Arduino IDE를 엽니다.
  1. Arduino IDE가 열립니다. 파일»열기를 클릭하고 C:\Program Files\National Instruments\LabVIEW 201x\vi.lib\LabVIEW Interface for Arduino\Firmware\LIFA_Base에있는 LIFA_Base.ino를 찾습니다.
  2. 참고: 이전 버전의 LIFA 툴킷은 위와 동일한 위치에 있는 LVIFA_Base.pde 파일을 사용합니다.
  1. Tools»Board»Arduino Uno를 클릭하여 Arduino 보드 유형을 선택합니다.
  2. Tools » Serial Port를 클릭하고 Arduino Uno에 해당하는 COM 포트를 선택하여 COM 포트를 선택합니다.
  1. 시작»제어판»장치 관리자를 클릭하고 포트(LTP 및 COM)를 확장하여 장치 관리자를 사용하여 Arduino Uno에 해당하는 COM 포트를 확인할 수 있습니다.
  2. 업로드 버튼을 클릭하여 Arduino Uno에 펌웨어를 업로드합니다.
  1. Arduino IDE는 펌웨어가 Arduino에 성공적으로 업로드되면 업로드 완료를 보고해야 합니다.
  1. 이제 Arduino Uno용 LabVIEW 인터페이스와 함께 Arduino Uno를 사용할 준비가 되었습니다. LIFA 툴킷에는 함수 팔레트를 통해 액세스 할 수 있는 여러 예제가 포함되어 있습니다. 시작하기에 좋은 곳입니다.