Can I Use the XNET Compatibility Layer on a Real-Time Target?

Updated Nov 21, 2019

Reported In

Driver

  • NI-XNET
  • NI-CAN

Issue Details

I am unable to install the XNET Compatibility Layer onto my real-time controller. How do I properly accomplish this?

Solution

The XNET Compatibility Layer is limited to work with hardware that is supported by the NI-CAN driver. Phar Lap and LinuxRT are not supported operating systems for NI-CAN.

cRIOs are not supported with NI-CAN. C Series CAN Modules only work with cRIOs using XNET or FPGA.