Does LabVIEW Leave Files In My Temporary Directory?

Updated Mar 1, 2019

Reported In

Software

  • LabVIEW

Issue Details

I noticed files with the format uarcxxxx.vi and lvtxxxx.rsc in my Windows temporary directory. Did LabVIEW leave these files in my temporary directory?

Solution

Yes, LabVIEW may create several different types of files in your temporary directory. To view or change the temporary directory path in LabVIEW 6.x and later, go to Tools»Options»Paths»Temporary Directory. To view or change the temporary directory path in LabVIEW 5.x, go to Edit»Preferences»Paths»Temporary Directory.

LabVIEW uses this directory to store log files that are generated after an internal error occurs. LabVIEW also uses this directory to store a number of temporary files while executing; if your VI or LabVIEW is not terminated gracefully, some files may not be removed automatically from your temporary directory. It is safe to delete any LabVIEW files from your temporary directory when the files are not in use (when LabVIEW is not running).