使用LabVIEW为Linux目标创建VeriStand模型出现错误-4500

更新 Nov 6, 2020

适用于

软件

  • LabVIEW
  • VeriStand
  • VeriStand Model Generation Support for LabVIEW

操作系统

  • NI Linux Real-Time

问题详述

当我使用LabVIEW为NI Linux Real-Time(LinuxRT)目标创建VeriStand模型时,出现错误代码-4500。我该如何解决此错误?

解决方案

在安装用于NI Linux Real-Time Targets的VeriStand LabVIEW模型之前,必须先下载驱动程序和模块,并将其安装在计算机上。 所需的软件是LabVIEW Real-Time模块CompactRIO驱动程序NI VeriStand 和用于Linux的C / C ++开发工具 。 成功安装这些依赖项后,您将能够在LabVIEW中为Linux RT目标导出VeriStand模型。

相关信息

  • 通常,导出的模型的格式为.lvmodel 。对于Linux目标,格式为.lvmodelso
  • 导出模型之前,请首先检查目标文件夹中没有相同名称的模型。如果已有模型(即使格式不同),则导出将不会成功。