Why AM 9898 Module Is Not Recognized on cRIO-904x and cRIO-905x Series?

Updated Nov 7, 2019

Reported In

Hardware

  • cRIO-9045
  • cRIO-9047
  • cRIO-9042
  • AM-9898
  • cRIO-9048
  • cRIO-9049
  • cRIO-9056
  • cRIO-9052
  • cRIO-9053
  • cRIO-9055
  • cRIO-9057
  • cRIO-9054
  • cRIO-9058

Issue Details

I would like to use AM 9898 module with cRIO-9045. I installed all necessary software, including the module driver. However, I can't use the module with the following message in a LabVIEW project.

Solution

The AM 9898 module is not supported in newer CompactRIO controllers, such as the cRIO-904x and cRIO-905x.

If you must use this module, you can use a CompactRIO that does not support NI-DAQmx or utilize a HART converter. For example, there are HART to Serial or HART to Modbus interfaces that could be utilized to convert the HART signal to be read with NI-VISA or with LabVIEW Datalogging and Supervisory Control Module.

Additional Information

The module was developed with the Module Development Kit (MDK) version 2.0, which can be confirmed in the 9898 user manual. The cRIO-904x and cRIO-905x are a new family of controllers that utilize a newer version of the MDK so they can support different programming modes, such as Real-Time (DAQmx), Real-Time Scan (RSI), and LabVIEW FPGA (FPGA I/O Nodes). Because of this, the AM 9898 will not work as is with CompactRIO controllers that use a version of MDK that is newer than 2.0.