Multisim Version 10.x Support for Windows 7

Updated Dec 6, 2019

Reported In

Software

  • Multisim
  • Circuit Design Suite
  • Multisim 10.0.1 Full
  • Multisim 10.1 Full
  • Multisim 11.0 Full

Operating System

  • Windows

Issue Details

Is NI Multisim version 10.0 & 10.1 supported in Windows 7?

Solution

NI Multisim version 10.0 and 10.1 which are a part of NI Circuit Design Suite 10.0 and 10.1 respectively are not compatible with Windows 7. NI Circuit Design Suite 10.0 and 10.1 supports the following operating systems:
  • Windows Vista/XP/2000 32-bit editions
  • Windows Vista 64-bit edition

Additional Information

The Circuit Design Suite combines Multisim and Ultiboard software to offer a complete set of tools for circuit design, simulation, validation, and layout. The minimum version of NI Circuit Design Suite compatible with Windows 7 is 11.0 or higher.