Missing Icons on Functions or Controls Palette in LabVIEW 7.0 or Earlier

Updated Jan 25, 2019

Reported In

Software

  • LabVIEW

Issue Details

  • The functions or controls palette is missing icons, subpalettes, toolsets, or drivers.
  • I get a warning in LabVIEW saying Missing NI Module, Toolkit, or Driver.
  • I cannot find the .NET or ActiveX palettes.

Solution

This KnowledgeBase article refers to LabVIEW 7.x or earlier. For similar information and troubleshooting for LabVIEW 8.0 or newer, see Missing Icons on LabVIEW Functions or Controls Palette.
 

The functions or controls palette may be missing icons or subpalettes for several different reasons. First ensure that you are using a LabVIEW Development System that is compatible with your module or toolkit that is missing. If your software is compatible and you are missing icons or subpalettes, please refer to the section below that describes your particular problem.   
 

I. Functions or Controls Palette is Blank

LabVIEW 6.x/7.x: 

  1. Select Tools»Options and then select Paths from the drop-down menu.
  2. Then select Library Directory from the drop-down menu and confirm that the Use Default box is checked.

LabVIEW 5.x and Earlier: 

  1. Select Edit»Preferences... and then select Paths and Library Directory from the drop-down menus.
  2. Confirm that the Use Default box is checked.
Another path to check is the Menus Directory. Instead of selecting Library Directory, select Menus Directory. Ensure that the path listed is correctly pointing to the menus folder: labview\menus.


II. Icons or Palettes have Question Marks

If the icon has a question mark, or the palette is blank, then the file that the icon points to is in the wrong place, was deleted, or does not exist on your computer. See Why do Some Icons or Palettes Appear with Question Marks in LabVIEW? for troubleshooting steps. 
 

III. Icons or Palettes are Missing

LabVIEW 7.x

  1. Go to Tools»Advanced»Edit Palette Set
  2. Three windows will pop up: (a) the Edit Controls and Functions Palettes window, (b) the Controls window, and (c) the Functions window.
  3. Right click in empty space within the sub-palette and select Insert»Subpalette... or Insert»VI(s)...
  4. Select the link to an existing menu or VI file (.mnu or .vi) and click OK.
  5. Select Save Changes and exit and re-enter LabVIEW.

LabVIEW 6.1 and earlier

  1. Pin the function palette to the block diagram or front panel by clicking on the pin in the upper left hand corner.
  2. Click on Options (the icon does not appear unless the function palette is tacked and looks like two bullets).
  3. Select Edit Palettes.
  4. Within the Function Palette, navigate to the location where you would expect the icon to appear.
  5. Right click in empty space within the sub-palette and select Insert»Submenu (as shown below).
  1. Select the link to an existing menu file (.mnu) and click OK.
  2. Select the dir.mnu.*
  3. Select Save Changes and exit and re-enter LabVIEW.
If the icon is still not visible, place your LabVIEW installation CD in the CD drive and try a Modify or Repair on your instance of LabVIEW.

*If there is not a dir.mnu that you can directly select, you may have installed into a different directory and need to look there or you may have deleted this file. Please contact NI's Customer Phone Support for further assistance.
 

IV. Missing an Entire Category of Functions

If you are missing an entire palette in LabVIEW, then verify that the palettes you are looking for are not already in LabVIEW, but just marked as hidden.
  1. Right-click the block diagram to open the Functions palette.
  2. Select the double arrows at the bottom of the palette to expand it to full-size.
  3. Click Change Visible Palettes...
  4. Look through the list of palettes that appear for the one you are looking for. If you see it, make sure the check box next to it is checked. 
If you still cannot find the Palette you are looking for in the Available Palette Categories, make sure your VI is under the correct target in the project explorer window. Since different categories will appear depending on the target for example the .NET & ActiveX palette appear in the available palette categories only when the VI is under the PC target and not when the VI is under the Real Time or FPGA targets.
 

V. Newly Installed Toolset does not appear under the Functions Palette

Make sure that you have followed all download instructions, including installing software in the correct order and installing the toolset in the correct directory within LabVIEW. If you are currently running LabVIEW, exit and reopen LabVIEW. If the icon is still not visible, they may need to be manually added to the function palette as explained below in section IV.
 

VI. The NI-DAQ VIs Don't Appear in my LabVIEW Functions Palette

If you have LabVIEW 6.1 and upgrade to NI-DAQ 7.4.1 and LabVIEW 8.0, the DAQ palette from LabVIEW 6.1 will disappear. NI-DAQ 7.4.1 provides only LabVIEW 8.0, 7.1, and 7.0. support. In order to get Traditional NI-DAQ support for LabVIEW 6.1 while LabVIEW 8.0 is still installed, it is necessary to load the NI-DAQ 7.4 driver which will remove the Traditional DAQ support for LabVIEW 8.0. It is still possible to load NI-DAQmx 8.0 in order to have the latest DAQmx support in LabVIEW 8.0. See Traditional DAQ Palette Does Not Appear In LabVIEW for more information.
 

Additional Information

If you have subVIs in your VI that belong to a Module or Toolkit that you do not have installed, they will be grayed out.

WAS THIS ARTICLE HELPFUL?

Not Helpful