How to Configure LIN Protocol Version

Updated Mar 7, 2019

Reported In

Hardware

  • PCI-8516
  • USB-8506
  • PXI-8516
  • NI-9866

Driver

  • NI-XNET

Issue Details

I am using LIN device with NI-XNET. I know my hardware supports various LIN protocol versions. How can I configure my LIN protocol version to 2.1?

Solution

LIN protocol version is configured when creating LIN database. You can set the protocol version in each ECU properties. This can be done by using NI-XNET Database Editor or LIN:Protocol Version property. There are two options you can set the property value.
 
  • Use NI-XNET Database Editor.
When creating a database by NI-XNET Database Editor, you can configure the LIN protocol version with it. For example, if you open an existing database NIXNET_exampleLDF, you can set Protocol Version of Master and Slave devices in <ECUs> tab which configures ECU properties.
 

 
  • Use LIN:Protocol Version property.
When creating a database dynamically, you can set the LIN protocol version in a programmable way using LIN:Protocol Version property.
 

In order to set this property, follow instructions below:
  1. Right-click on the block diagram and navigate to Measurement I/O » XNET » Database. Place XNET ECU Property Node on the block diagram.
  2. Click ECU Node and select LIN » Protocol Version to change LIN:Protocol Version property.
  3. Right-click ECU Node and select Change All To Write. Create constant or control to select the protocol version.

Additional Information

ECU configuration has to be done before opening XNET session for dynamic database creation.
For more information about programming flow, please see the example LIN Dynamic Database Creation.vi in the NI Example Finder.

WAS THIS ARTICLE HELPFUL?

Not Helpful