如何通过NI汽车诊断命令集工具包使用基于IP的诊断(ISO 13400-2)

更新 Mar 23, 2021

环境

软件

  • Automotive Diagnostic Command Set Toolkit
  • LabVIEW

我正在尝试使用NI Automotive Diagnostic Command Set Toolkit 18.0通过IP执行诊断,但是我的ECU仍然没有响应。我调试了与WireShark的通信,结果得到以下错误。



我的ECU要求使用ISO 13400-2版本的DoIP。根据ADCS产品概述,包括对ISO 13400的支持。 ADCS工具包是否也支持ISO 13400-2版本?

已对ISO 13400文档进行了修订,包括了其他功能。此修订通常使用冒号记录,例如“ ISO 13400-2:2010”或“ ISO 13400-2:2012”

ADCS 18.0和更早版本仅支持ISO 13400-2:2010
ADCS 18.5引入了对ISO 13400-2:2012的支持。

在您的情况下,您的ECU必须使用ISO 13400-2:2012,因此解决此问题的方法是使用ADCS 18.5