Requirements to Communicate With a WF3144 Module

Updated May 21, 2020

Reported In

Hardware

  • NI-9145

Software

  • LabVIEW
  • LabVIEW Real-Time Module
  • LabVIEW FPGA Module

Driver

  • NI-RIO

Issue Details

  • I have a WF 3144 module.¬†What do I need to communicate with it?
  • Which version of NI-RIO do I need in order to see the WF 3144 I/O under a LabVIEW Real Time or FPGA project?

Solution

In order to create a project using a WF3144, you need to have installed in your computer:
  • LabVIEW Full (version 2017 SP1 or higher)..
  • LabVIEW FPGA Module
  • NI CompactRIO driver (version 17.6 or higher).
  • VI Package Manager in order to download the LabVIEW driver for the device.
Also, you will need a CompactRIO from C Series chassis with LabVIEW FPGA programming enabled.

Additional Information

Since this is a third party module, for support with this device and it's programming, please contact WireFlow support .