Can I Create an Installer for an Application That Was Developed Using an Older Version of Labview?

Updated Sep 24, 2019

Reported In

Software

  • LabVIEW
  • LabVIEW Application Builder Module

Operating System

  • Windows

Issue Details

I have a LabVIEW application (exe) that was made using a specific version of LabVIEW. I wish to create an installer for the same using a development environment of LabVIEW that is a higher version than the one used to create the application. Is it possible to do this?

Solution

Yes, it is possible to create an installer with a LabVIEW development environment of a higher version as compared to the version in which the application was built.

To do this, add the exe to a LabVIEW project and create an installer. Make sure you have LabVIEW's RTE corresponding to version needed by the exe installed on the system. When creating the installer, manually select this version of the RTE.