Problem Accessing the Database When Launching Multisim

Updated Aug 18, 2026

Reported In

Software

  • Multisim
  • Ultiboard

Issue Details

When I launch Multisim I get error messages saying there was a problem opening the database. Multisim then opens fine, but I cannot select any parts from the databases, they are empty.

The error message is similar to this one (it might say Master, Corporate or User):

Problem: Accessing the database.

The Master Database cannot be accessed. Features using the Master Database will not be available.

Why is this happening and how can I get this fixed?

Solution

By default, NI Circuit Design Suite (Multisim / Ultiboard) stores database files in a hidden system directory in Windows.

  • Default Master Database Path:
    C:\ProgramData\National Instruments\Circuit Design Suite\<Version>\database\
  • Accessing Hidden Folders: Because C:\ProgramData is hidden by default in Windows Explorer, perform one of the following to access it:
    • Enable hidden items in Windows File Explorer via View » Show » Hidden items.
    • Alternatively, copy and paste the path above directly into the address bar of Windows File Explorer or the file browser window.

There can be multiple reasons to get this error message in Multisim; however, the two main reasons are either you have a corrupted User Configuration file or you have a corrupted Jet Engine registry key in the Windows Registry. This KB will explain how to solve the user configuration file case first, followed by the registry key problem.

If Multisim or Ultiboard cannot locate the target database file or query components:

  1. Launch Multisim or Ultiboard.
  2. Navigate to Options » Global Preferences.
  3. Select the Paths tab.
  4. Under the Database Files section, locate the Master Database path field.
  5. Click Browse and navigate to: C:\ProgramData\National Instruments\Circuit Design Suite\<Version>\database\
  6. Select the master database file (e.g., Master_Database.mcdb or MCDB.mcdb) and click Open.
  7. Click Apply and OK to save the changes.


Corrupted User Configuration File

You can attempt to force Multisim to create new User Configuration files. This will reset all your user preferences to the defaults.

  1. Make sure Multisim is closed
  2. Delete all files in the following folder:

    C:\Program Files(x86)\National Instruments\Circuit Design Suite <version>\config

    * Replace <version> with the Multisim version you are running, e.g. 14.3.
     
  3. Open Multisim again; the databases and the user interface should be back to defaults

If you still cannot load the databases, read the next section to fix the registry.


Corrupted Jet Engine Registry

The next common reason for Multisim to be unable to load the databases is due to a corrupted registry entry. We are aware of 3rd party software that modifies the Microsoft Jet Engine registries upon installation, and in most cases after uninstalling that software. The end result is that Multisim is unable to find the Jet Engine since the registry keys point to somewhere else.

In Windows 32-bit systems, the keys are located in:
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0]

In Windows 64-bit systems, the keys are located in:
[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Jet\4.0]

The only way to fix this issue is to rewrite the corrupted registries through one of the following ways:

WARNING: Inappropriate changes to the Windows Registry can disable your operating system. Only follow these instructions if you are comfortable making these changes, otherwise enlist the help of your system administrator or call NI Applications Engineers. Before attempting these steps, make a backup copy of your existing registry by launching the Registry Editor, highlight the top-level Computer entry and select File»Export. Save the copy in case you need to restore the registry.

  • Using another computer
    • In a second computer that is working fine open the Windows Registry Editor
      • In Windows go to Start»Run
      • Type regedit, press OK
    • Navigate to the corresponding registry key as noted above depending on the Windows system that you have (32-bit or 64-bit)
    • Right-click the key directory and select Export
    • Save to a .reg file and close the Registry Editor
    • Copy the exported file to the corrupted computer
    • Double-click the .reg file and follow all Windows prompts to import
      Note: for this step you may need Administrator rights, you may also open the Windows Registry Editor and select File»Import.
    • Restart the computer and launch Multisim, it should now work
  • Using the attached registry files - These files were created from a clean Windows 7 test machine. They were found to be valid for XP and Vista also.
    • Download the corresponding file from the Attachments section:
      • For 32-bit systems: Jet4Win7x86.zip
      • For 64-bit systems: Jet4Win7x64.zip
    • Unzip the downloaded file to locate the .reg file.
    • Double-click the .reg file and follow all Windows prompts to import
      Note: for this step you may need Administrator rights, you may also open the Windows Registry Editor and select File»Import.
    • Restart the computer and launch Multisim, it should now work
  • Reset Windows 10 - If you are using Windows 10, the attached registry files may not fix the issue. A reset of Windows 10 is a potential solution. In the related links there is an explanation from Microsoft Support on how to do it.