Error: Missing NI CompactRIO Driver Support for LabVIEW

Updated Mar 27, 2019

Reported In

Software

  • LabVIEW
  • LabVIEW FPGA Module
  • LabVIEW Real-Time Module
  • NI Device Drivers

Issue Details

I just installed a new version of LabVIEW, and when I try to run VIs on my cRIO, I get an error that says "Missing NI CompactRIO Driver Support" for my new version of LabVIEW. How can I fix this?

Solution

This error can be resolved by making sure you have the following software installed on your system: If you already have all of this software, the issue might be that the device drivers were not correctly linked to your new version of LabVIEW. To ensure that everything is linked correctly, uninstall and reinstall the NI CompactRIO Device Drivers.