ISE 14.7的Xilinx编译工具不正式支持Windows 8或更高版本

更新 Jul 22, 2020

适用于

软件

  • LabVIEW FPGA Module
  • LabVIEW
  • FPGA Xilinx Compilation Tools

其他


 

问题详述

尝试在运行Windows 10的计算机上安装LabVIEW和FPGA模块时,出现以下错误:

或者:

解决方案

1.请注意,在向导的“选择安装”页面中选择LabVIEW 2018 FPGA进行安装时,会自动选择Xilinx编译工具– ISE 14.7。在上面单击下一步将导致上述错误。

2.选择不安装 Xilinx编译工具– ISE 14.7

3.出现一个窗口,询问“您要取消选择从属产品吗?”出现,选择否。

4.使用NI LabVIEW FPGA编译云服务或在单独的Windows 7 PC上设置远程LabVIEW FPGA编译场

相关信息

ISE安装程序适用于较老系列的产品–虽然目前仍然可以使用,但由于很多人都在更新的过渡期或当前正在使用较新的芯片,因此Xilinx并未积极地研发该系列产品的编译器。但是,Xilinx推出了Vivado 2017编译器,该编译器支持其芯片和Windows 10的大多数活动产品系列。因此,除非您使用的是旧硬件,否则可以使用Xilinx Vivado编译工具。只要您的硬件在Xilinx编译工具和相应的NI硬件支持表的Vivado部分之一中列出,就可以不使用ISE编译器。