Selected Target Does Not Support this Function When Installing Software

Updated Aug 16, 2019

Reported In

Hardware

  • PXI Controller
  • CompactRIO Controller

Software

  • Measurement & Automation Explorer (MAX)
  • LabVIEW Real-Time Module

Driver

  • NI-DAQmx
  • PXI Platform Services

Issue Details

I am installing software on an RT target through NI MAX. When I click add/remove software, I get an error message stating:
The Selected Target Does Not Support this Function

Solution

This error is caused when NI MAX is unable to connect to your target. To resolve this error, NI MAX should be upgraded to the newest version supported by the hardware and software being used in your application.
 
  1. To upgrade NI MAX, install the corresponding version of the NI System Configuration API, CompactRIO drivers, or DAQmx
  2. If you are already using the newest compatible version of NI MAX then reinstall it using the same method as in step 1

 

Additional Information

Important note: upgrading NI MAX will mean you also need to upgrade DAQmx and PXI platform services, or CompactRIO drivers since these drivers require a version match with NI MAX. 

Make sure that the DAQmx, PXI Platform Services, and CompactRIO versions that you are installing will be compatible with the hardware used in your application.

WAS THIS ARTICLE HELPFUL?

Not Helpful