NI-9231 is Not Detected in Measurement & Automation Explorer (MAX)

Updated Oct 22, 2018

Reported In

Hardware

  • NI-9231

Software

  • LabVIEW Full
  • LabVIEW Professional

Driver

  • NI-DAQmx
  • NI CompactRIO

Issue Details

I have purchased an NI-9231 and connected it to my cDAQ chassis, but the module is not recognized in NI MAX. I have installed the NI-DAQmx driver and the other NI C Series modules are detected. How can I get my NI-9231 to be detected by my system?

Solution

The NI-9231 was released in June of 2018, so older versions of the NI-DAQmx driver do not provide support for this module. This module is only supported in NI-DAQmx 18.1 and later.

See Software Support for CompactRIO, CompactDAQ, Single-Board RIO, R Series, and EtherCAT for more information.

Additional Information

When you install the driver, you must consider the software compatibility with Windows OS and LabVIEW.
Additional compatibility information can be found in the driver readme. 

WAS THIS ARTICLE HELPFUL?

Not Helpful