"Higher Version Already Installed" Error When Running Custom Installer

Updated Apr 9, 2020

Reported In

Software

  • LabVIEW
  • LabVIEW Application Builder Module

Issue Details

When I run my custom installer, I receive the message, "Cannot install: Higher version already installed" on my deployment computer. How do I fix this?

Solution

If you are getting the error trying to install an Add-on or a NI Toolkit, you can refer to this article. Otherwise, follow the next steps:
  1. In the Build Specification for your installer, go to Version Information tab.
  2. Click the Generate button next to the Upgrade code field.
  3. Then click the Build button to compile your installer.
  4. Run it on the deployment computer.

Additional Information

When you create a custom installer, LabVIEW generates a global unique identifier (GUID) to identify your program. This is how version numbers are checked when installing software to a new computer. If you copy your LabVIEW project from one directory to another, and then try to create a new installer from that project, the GUID will not update. Therefore, the target computer will not recognize the updated installer as a new piece of software and will not permit the installation.