NI Linux Real-Time을 위한 LabVIEW 공유 라이브러리 버젼 호환성

업데이트 됨 Aug 19, 2020

해당 제품

소프트웨어

  • LabVIEW
  • VeriStand

운영 체제

  • NI Linux Real-Time

문의사항

  • LabVIEW 프로젝트 내에서 Real-Time Target을 위한 공유 라이브러리 (.so)를 구축하거나 구성하려고하면 GCC (GNU Compiler Collection)가 설치되지 않았다는 오류가 표시됩니다.
NI Linux Real-Time 타겟에 호환되는 공유 라이브러리를 구축하려면 어떤 버전의 GCC를 설치해야합니까?
  • LabVIEW 2017의 VI에서 Linux OS 타겟용 모델을 생성하려고합니다. 하지만, 가능한 대상 OS 드롭 다운 옵션중에는 Windows 및 Pharlap만 가능하다고 나와있습니다.

해결책

LabVIEW 프로젝트에서 공유 라이브러리를 구축하려면 아래 차트에 참조 된대로 적절한 버전의 NI Linux Real-time 용 C / C ++ 개발 도구가 설치되어 있어야합니다.
VeriStand 2017에서 사용하기 위해 모델에 빌드 할 LabVIEW 2017 코드를 작성하는 경우 Eclipse Edition 2014-2016이 필요합니다.

추가 정보

참고로 필요한 전체 소프트웨어 스택과 설치 순서는 다음과 같습니다.

  1. LabVIEW
  2. LabVIEW Real-Time 모듈
  3. LabVIEW FPGA 모듈
  4. VeriStand (LabVIEW와 연도 일치)
  5. CompactRIO 드라이버
  6. NI Linux Real-Time, Eclipse Edition 용 C / C ++ 개발 도구