Support for X Series DAQ Cards in Linux

Updated Aug 27, 2018

Reported In

Hardware

  • PCIe-6351

Driver

  • NI-DAQmx

Issue Details

I'm planning to use a PCIe-6351 card on a Linux Machine. I wanted to check the compatibility for X Series cards in Linux distributions.

Solution

Commonly, the driver used for DAQ devices on Linux machines was NI-DAQmx Base. The X Series cards are not supported even in the latest version (NI DAQmx Base 15.0).

On the other hand, with the new release of the NI Linux Device Drivers (July 2018), the support for X Series DAQ cards was added. Please review the table below to check the compatibility of your device. 
 

In the device support table above the "X" indicates that the device is supported, and "-" indicates that the device either does not exist or is not supported in NI-DAQmx.

 

WAS THIS ARTICLE HELPFUL?

Not Helpful