Glyphs Missing in LabVIEW Icon Editor

Updated Jul 3, 2019

Reported In

Software

  • LabVIEW

Operating System

  • Windows

Issue Details

When I try to create an Icon with the LabVIEW Icon Editor, no glyphs show up in the glyphs tab.

This is shown in the image below:

Solution

To add the missing glyphs, you will need to automatically or manually synchronize with the ni.com Icon Library. Before continuing to the below steps, make sure that the folder C:\Users\<User>\Documents\LabVIEW Data\Glyphs exists. If the folder exists proceed with the following steps. If the folder does not exist, create the folder before moving forward. 

Automatically Synchronize with ni.com Icon Library:

  1. ​​​​​​Open the Icon Editor Dialog Box by first opening up a LabVIEW VI. Select File»VI Properties (or File»Control Properties) to display the VI Properties dialog box (or Control Properties dialog box). Then select General from the Category pull-down menu and click the Edit Icon button.
  2. Within the Icon Editor, go to Tools»Synchronize with ni.com Icon Library. If you have access to the National Instruments Web server, this will start downloading the Icon Library automatically to LabVIEW.
This step is also shown in the image below:                                                                                                         

Manually Synchronize with ni.com Icon Library:

If LabVIEW displays the below error, this means LabVIEW cannot reach the National Instruments Web server. In this event, you will see the following error/ dialog box: 

LabVIEW cannot reach the National Instruments Web server. You must synchronize with the Icon Library Manually.
Click the Help button for more information about resolving this error.


The error is also shown in the dialog box below:


If you see the above error/ dialog box, you will need to manually synchronize the Icon Library. In order to synchronize manually follow steps 1 through 5 below. These steps are also described in the Synchronizing with the Icon Library Manually article. 
  1. From the Icon Library at ni.com, download the Icon_Library.zip file to an easily accessible location.
  2. Save the Icon Library XML file (right click link, save file as) to an easily accessible location. The Icon Library XML file determines the structure of the files in the Icon_Library.zip file.
  3. In the Synchronize Manually dialog box, enter the path to the Icon_Library.zip file in the Icon library ZIP file field.
  4. Enter the path to the icons_filtered.xml file in the Icon library XML file field.
  5. Click the OK button. LabVIEW populates the Synchronize with Icon Library dialog box with all icons from the .zip file and with a structure that the XML file defines.

WAS THIS ARTICLE HELPFUL?

Not Helpful