Prevent LabVIEW Error Dialog Box

Updated Aug 20, 2018

Reported In

Software

  • LabVIEW

Issue Details

I am using the error wires to propagate errors accordingly in LabVIEW. But even though I use wires and indicators, when an error happens I still get the Error pop up dialog. How can I disable it to just have the error in an indicator?

 

I don't care about the errors coming from my LabVIEW VI, but the LabVIEW error dialog box continues to appear. How do I ignore this error from the VI?

Solution

This dialog box is occurring because LabVIEW's Automatic Error Handling is turned On. The error dialog can be disabled in all new VIs by opening a blank VI and navigating to Tools>Options>Block Diagram, scrolling to Error Handling, and deselecting Enable automatic error handling in new VIs. This will disable automatic error handling in the block diagram for all newly created VIs in LabVIEW.



You can also, disable automatic error handling in a single VI by navigating to File>VI Properties>Execution. Or clicking Ctrl+i. See image



Note: The best practice would be to ensure you incorporate manual error handling. If you truly do not care about the output of a specific VI, you can use the Clear Errors VI to clear the error and not have Automatic Error Handling catch and display the dialog box. 

Additional Information

This can also be acheived by adding the following tokens to the LabVIEW ini file:
defaultErrorHandlingForNewVIs: False
EnableAutomaticErrorHandling: False

WAS THIS ARTICLE HELPFUL?

Not Helpful