Error -1074135040 with Third Party Hardware

Updated Aug 7, 2019

Reported In

Driver

  • IVI Compliance Package

Issue Details

I am interacting with a piece of third party hardware with GPIB, and whenever I run my VI to connect to the device, I get error -1074135040: IVI Unrecoverable Error. Typically the error occurs while the device is being initialized.

Solution

The IVI Compliance Package is most likely out of date or not installed on this machine. Please download the latest version that is compatible with your National Instruments software (e.g. LabVIEW) from our website.

To determine the compatibility of the IVI Compliance Package with your NI software, check the IVI Compliance Package readme, available on the download page for each version.

 

Additional Information

The NI IVI Compliance Package is a software package that contains IVI-class drivers and support libraries necessary for the development and use of applications that use IVI instrument interchangeability. The IVI Compliance Package is based on and compliant with the latest version of the instrument programming specifications defined by the IVI Foundation.

WAS THIS ARTICLE HELPFUL?

Not Helpful