MIG Strings Unresolved Dependency Installing Software on RT Target

Updated Jun 27, 2018

Reported In

Software

  • LabVIEW Real-Time Module

Driver

  • NI-DAQmx

Issue Details

I get an unresolved dependency error when I attempt to install software onto my RT controller. It looks similar to the following:
Cannot continue because of the following unresolved dependencies:
Multifunction DAQ 15.1.1 requires MIG Strings 15.1.0
Industrial Digital I/O 15.1.1 requires MIG Strings 15.1.0
Analog Output Series 15.1.1 requires MIG Strings 15.1.0

Posible reason: The feature's Real-Time Support for this target type may not be installed.




Why do I get this error, and how can I resolve it?
 

Solution

Before installing DAQmx in the RT Target, install Real-Time support when you select features installing NI-DAQmx on the development/host PC. This will install Real-Time (RT) images to the host machine which can then be installed on the RT device using the Real-Time Software Wizard in MAX. 


 

WAS THIS ARTICLE HELPFUL?

Not Helpful