OPC UAツールキットおよびLabVIEWバージョンとの非互換性エラー

更新しました Aug 19, 2019

使用製品

Software

  • LabVIEW
  • LabVIEW OPC UA Toolkit

問題

LabVIEW 2016以前がインストールされているコンピュータにNI OPC UA Toolkit 2017をインストールすると、非互換性エラーが発生します。インストールできる旧バージョンのNI OPC UA Toolkitはありますか?

解決策

OPC UA APIには以前のバージョンがありますが、LabVIEWデータロギングおよび監視制御(DSC: Datalogging and Supervisory Contro)モジュールに含まれています。
 

LabVIEW 2016以前のOPC UA APIをインストールするには、互換性のあるLabVIEW DSCモジュールバージョンをインストールします。LabVIEW DSCモジュールのreadmeで互換性を確認できます。

追加情報

バージョン2017のリリースから、LabVIEW OPC UAツールキットはスタンドアロン製品になりました。LabVIEW DSCモジュールおよびLabVIEW Real-TimeにはOPC UA APIが含まれなくなりました。

この記事はお役に立ちましたか?

いいえ