Incompatibility Error with OPC UA Toolkit and LabVIEW Versions

Updated Mar 6, 2018

Reported In

Software

  • LabVIEW
  • LabVIEW OPC UA Toolkit

Issue Details

When I install NI OPC UA Toolkit 2017 on my computer with LabVIEW 2016 or earlier, I receive an incompatibility error. Is there an earlier version of the NI OPC UA Toolkit that I can install? 

Solution

There are previous versions of the OPC UA API available, but they are included in the LabVIEW Datalogging and Supervisory Control (DSC) Module.

To install the OPC UA API for LabVIEW 2016 or earlier, install the compatible LabVIEW DSC Module version. You can check compatibility in the LabVIEW DSC Module readme for your version. 

Additional Information

From the 2017 release, the LabVIEW OPC UA Toolkit became a standalone product. The LabVIEW DSC Module and LabVIEW Real-Time no longer contain the OPC UA API. 

WAS THIS ARTICLE HELPFUL?

Not Helpful