LabVIEW FPGA를 위한 지원 소프트웨어가 설치되지 않음

업데이트 됨 May 29, 2019

해당 제품

Software

  • LabVIEW FPGA Module
  • LabVIEW Full
  • LabVIEW Professional

문의사항

FPGA 타겟을 사용하는 LabVIEW 프로젝트를 열면 FPGA 타겟이 노란색 느낌표로 되어 있습니다.

Explain Warning을 클릭하면 다음의 두 가지 에러 중 하나가 발생합니다.
  • 이 FPGA 타겟에 대한 소프트웨어 지원이 컴퓨터에 설치되어 있지 않습니다. 프로젝트의 일부 아이템을 보거나 복사할 수 있지만 타겟을 지원하는 소프트웨어를 설치할 때까지 이 FPGA 타겟 아래의 VI를 컴파일 할 수는 없습니다. 적절한 드라이버, FPGA 타겟 설치 및 설정에 대한 정보는 해당 하드웨어 문서를 참조하십시오.
  • 선택한 항목의 플러그인이 시스템에 설치되어 있지 않거나 플러그인의 라이센스가 만료되었습니다. National Instruments에 문의하십시오.

이 문제를 어떻게 해결할 수 있습니까?

해결책

이 에러 메시지는 LabVIEW 개발 환경과 LabVIEW FPGA 모듈 간의 연결이 끊어졌음을 나타냅니다. 이 문제를 해결하려면 다음과 같이 하십시오.
  1. NI Measurement and Automation Explorer (MAX)에서 FPGA 모듈이 설치되어 있는지 확인하십시오. 내 시스템»소프트웨어»LabVIEW (버전) 항목을 확인하여 FPGA 모듈이 사용중인 LabVIEW 버전의 드롭 다운 메뉴 아래에 있는지 확인하십시오.
참고: LabVIEW FPGA Module은 2017 버전에서 오직 32비트 버전의 LabVIEW Full 및 LabVIEW Professional과 호환됩니다. 64비트 버전의 LabVIEW FPGA Module 은 2018년에 출시되었습니다. 또한 LabVIEW FPGA Module은 오직 같은 버전의 LabVIEW와 호환됩니다.

  1. NI 라이센스 관리자를 체크하여 FPGA 모듈에 유효한 라이센스가 있는지 확인하십시오. 라이센싱 상태를 결정하는 방법에 대한 더 자세한 정보는 다음 링크를 참조하십시오. 링크: What Do the Colored Icons in NI License Manager Mean?
  2. NI MAX를 체크하여 사용 중인 LabVIEW 및 하드웨어가 설치된 NI-RIO 드라이버 버전과 호환되는지 확인하십시오.
    1. NI-RIO 및 LabVIEW 버전 호환성
    2. CompactRIO, CompactDAQ, 단일 보드 RIO, R 시리즈 및 EtherCAT에 대한 소프트웨어 지원
  3. NI 소프트웨어 제품의 설치 순서를 참고하여 올바른 소프트웨어 설치 순서를 따르십시오.
  4. FPGA 모듈의 라이센스가 있고 NI MAX에 나타나지만 여전히 이 오류가 나타나면 FPGA 모듈의 설치 상태가 손상되었을 수 있습니다. 
    1. FPGA 모듈을 강제로 다시 설치하려면 다음 링크를 참고하여 문제 해결 단계를 따르십시오. 링크: 작동하지 않거나 손상된 NI 소프트웨어 강제 설치 제거
    2. CompactRIO 드라이버를 복구하려면 Windows에서 National Instruments 소프트웨어 또는 드라이버 제거 또는 복구의 단계를 따르십시오. (올바른 순서에 따라 소프트웨어를 설치).

추가 정보

참고: LabVIEW 2015부터는 NI-RIO가 3개의 개별 설치 프로그램으로 분리되었습니다.
  • CompactRIO 디바이스 드라이버 (CompactRIO 및 단일 보드 RIO 지원).
  • R 시리즈 다기능 (R 시리즈 카드 지원).
  • FlexRIO (FlexRIO 보드 지원).
NI-RIO 및 LabVIEW 호환성 테이블은 모든 개별 설치 프로그램에 적용됩니다.

이 글이 도움이 되셨습니까?

도움 안됨