当前NI软件版本不支持C系列模块

更新 Oct 7, 2021

适用于

硬件

  • NI-9862
  • cRIO-9048
  • NI-9262

软件

  • LabVIEW

驱动

  • NI-XNET
  • NI-RIO
  • NI CompactRIO
  • NI-WSN

问题详述

  • 尝试将C系列的模块添加到我的LabVIEW项目中,出现"This C Series Module is Not Supported By This Version of LabVIEW and NI-RIO"
  • 我的EtherCAT扩展机箱,出现了报错 "This module is not supported by the current version of NI-Industrial Communications for EtherCAT"
image.png

我该如何解决这个问题?

解决方案

此错误可能是由不同的原因引起的,具体取决于错误信息。一般上,当发生此错误时,这意味着您所安装的当前驱动程序和尝试使用的硬件存在一些兼容性问题。有关解决此问题的帮助,请参见以下内容:

故障排除步骤

您的CompactRIO驱动程序版本可能是不支持您的硬件。您可以参考有关CompactRIO,CompactDAQ,Single-Board RIO,R系列和EtherCAT的软件支持文档,选择您想查看软件支持的设备,并升级该模块或驱动程序,以确保您能使用该硬件。

备注:若您要购买新硬件时,此页面也是一个很好的资源,因为您可以预先检查硬件是否已被您所拥有的软件支持。

如果问题在NI 914x EtherCAT扩展机箱上发生

  • 确保已在LabVIEW和控制器上安装了用于NI-​Industrial Communications for EtherCAT,并且确认与您正使用的LabVIEW版本兼容 。您可以通过查看EtherCAT驱动程序中的自述文件来检查LabVIEW-EtherCAT兼容性。
  • 有时在扩展机箱上可能会发生此问题,因为机箱上使用了已过时的固件版本。请按照机箱用户手册 中的步骤尝试升级设备上的固件。

如果问题在NI 986x XNET模块上发生

  • 确保已安装NI XNET,并且与您使用的LabVIEW版本兼容。您可以通过查看XNET驱动程序中的自述文件来检查LabVIEW XNET的兼容性。
  • 确保在cRIO本身上安装了XNET驱动程序。您可以阅读软件安装教程以获取有关此步骤的帮助。
  • 还要检查您的XNET驱动程序版本的自述文件,以确保您使用的机箱支持XNET。
    • 以太网RIO扩展机箱(NI-9146,NI-9147,NI-9148,NI-9149)和EtherCAT RIO扩展机箱(NI-9144,NI-9145)与986x模块不兼容。
    • 可以在Supported Hardware章节  找到相关信息

如果问题在NI-WSN模块上发生

  • NI-WSN仅在NI LabVIEW 2015及某些之前的版本中受支持。您可以通过查看NI-WSN驱动程序中的自述文件来检查兼容性。

相关信息

  • 对于904x系列机箱,请确保将模块添加到实时资源下,而不是在FPGA目标或实时扫描资源下。这将导致类似的错误。