Error Installing LabVIEW DSC Module in LabVIEW

Updated Feb 28, 2019

Reported In

Software

  • LabVIEW
  • LabVIEW Datalogging and Supervisory Control Module

Issue Details

Even though I have LabVIEW software installed, when trying to install the LabVIEW Datalogging and Supervisory Control Module (DSC Module), the process is interrupted with the following error message displayed:

NI LabVIEW 201x must be installed before you can install NI LabVIEW 201x Datalogging and Supervisory Control Module.
 

Why do I see this error, and how can I solve this issue?

Solution

The DSC Module is not compatible with LabVIEW 64-bit. It is only compatible with LabVIEW 32-bit. If you have LabVIEW 64-bit, the DSC installation will not detect LabVIEW and generates the error message seen in 'Issue Details'.

Therefore, you must ensure you have LabVIEW 32-bit installed even if you use a 64-bit OS.

Additional Information

It is possible to have LabVIEW 32-bit and LabVIEW 64-bit installed concurrently on the same machine.  They will not interfere with one another and are seen as separate programs.

WAS THIS ARTICLE HELPFUL?

Not Helpful