XML File Error When Attempting to Update WSN Node Firmware

Updated Jul 10, 2018

Reported In

Driver

  • NI-WSN

Operating System

  • Windows

Issue Details

I have NI-WSN 1.0 installed, and when I try to update any WSN node firmware, I get an error message.  This error message may state something regarding an XML File Error. How can I update my node firmware?

Solution

It's possible that the firmware currently on the WSN gateway is higher than the gateway firmware distributed with the NI-WSN 1.0 driver.  (The gateway firmware distributed with the NI-WSN 1.0 driver is 1.0.0.)  If this is the case, there are two solutions​
  • Upgrade the NI-WSN 1.0 driver on the computer.
  • Upload firmware from the NI-WSN 1.0 driver to the gateway such that there is no mismatch between the gateway firmware and the default firmware distributed with NI-WSN 1.0 driver, which is version 1.0.0.

WAS THIS ARTICLE HELPFUL?

Not Helpful