Do I Need to Install All of My Old Versions of LabVIEW?

Updated Feb 15, 2018

Reported In

Software

  • LabVIEW

Issue Details

I have multiple previous versions of LabVIEW, and I am not sure if i need to have all of them installed. I have several applications written in LabVIEW releases from 2012 to 2017 and I want to make sure they all still work.

Solution

LabVIEW releases are backwards compatible through several previous versions. A chart of version compatibility is available in this tutorial. Opening files from previous compatible versions in a newer release will automatically update the file to the newest version.

Additional Information

If you have built applications in a previous release, you will want to rebuild the application installer in the most recent release and include the proper Run-Time Engine.

WAS THIS ARTICLE HELPFUL?

Not Helpful